[Mandriva] passage 2007.1 à 2008.1 [Résolu/Fermé]

Signaler
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
-
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
-
Bonjour,

Ben je sais pô comment je me suis débrouillé mais je suis passé à la Mandriva 2008.1 !

Enfin, je sais comment j'ai fait ! j'ai choisi "Mandriva 2008.1" pour mes sources sur le site easyurpmi !
Ensuite 1787 paquets à installer !
Le système s'occupe de tout en me désinstallant les paquets de l'ancienne version (2007.1) tout seul comme un grand !


2 message d'erreur à régler maintenant :

1) le shorewall
FATAL: Module ip_set not found.

pour celui-ci il semble que cela soit un bug :
http://expert.mandriva.com/question/101111

correction possible : http://blogdrake.net/node/9685


2) hpiod
Starting hpiod: ./hpiod: error while loading shared libraries: libnetsnmp.so.10: cannot open shared object file: No such file or directory


ensuite :
3) fail2ban ne démarre plus

voici pour l'instant !

13 réponses

Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
462
bon ! j'ai réglé le souci fail2ban qui ne voulait plus démarrer ! en voici l'explication !

dans mon nouveau fichier /etc/fail2ban/fail2ban.conf j'avais :
socket = /var/run/fail2ban/fail2ban.sock

que j'ai remplacé par :
socket = /tmp/fail2ban.sock


ensuite il n'y a plus qu'à :
[root@mandriva fail2ban]# /sbin/service fail2ban start
Starting fail2ban:                                              [  OK  ]
[root@mandriva fail2ban]#



ps : j'ai rajouté ceci :
FAIL2BAN_OPTIONS="-x"


bien une première chose de réglée ....
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
462
ensuite j'ai réglé à nouveau mon pare-feu !

du coup je n'ai plus le message suivant :FATAL: Module ip_set not found puisque j'ai désactivé shorewall pour appliquer mon propre script iptables !


reste deux choses à voir :
Starting hpiod: ./hpiod: error while loading shared libraries: libnetsnmp.so.10: cannot open shared object file: No such file or directory
                                                                [ÉCHEC ]


pourtant :
[root@mandriva log]# rpm -qa | grep net-snmp
net-snmp-utils-5.4.1-5mdv2008.1
net-snmp-mibs-5.4.1-5mdv2008.1
net-snmp-5.4.1-5mdv2008.1
libnet-snmp-devel-5.4.1-5mdv2008.1
libnet-snmp15-5.4.1-5mdv2008.1
[root@mandriva log]#


et :
Lancement du service mandi : unable to open white list file
nl_bind_socket: No such file or directory
bind failed
unable to init netlink
unable to init "Interactive Firewall" plugin
                                                                [  OK  ]

ici, je rappelle que j'ai désactivé shorewall !



il n'y a plus qu'à "étudier" la bête ....et tout ça avec le dernier noyau :

[root@mandriva log]# uname -r
2.6.25.4
[root@mandriva log]#

:-))


Edit : un autre truc à voir, trouvé dans le fichier /var/log/syslog
May 18 14:13:35 mandriva kernel: glxinfo[5503]: segfault at 0 ip b7f6baaf sp bfbe935c error 4 in libGL.so.71.86.04[b7f3b000+61000]
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
462
bon ! problème réglé pour le message trouvé dans le fichier /var/log/syslog :
May 18 14:13:35 mandriva kernel: glxinfo[5503]: segfault at 0 ip b7f6baaf sp bfbe935c error 4 in libGL.so.71.86.04[b7f3b000+61000]

à rapporter probablement à l'erreur trouvée dans le fichier xorg.0.log
(EE) GLX is not supported with the Composite extension

ma solution :ouvrir le fichier /etc/X11/xorg.conf et ajouter ceci :
Option "Composite" "Disable"

....ça règle le problème !

Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
462
ok reste donc deux choses à voir :

1)
Starting hpiod: ./hpiod: error while loading shared libraries: libnetsnmp.so.10: cannot open shared object file: No such file or directory
                                                                [ÉCHEC ]

voir avec hplip
[root@mandriva log]# /sbin/service hplip status
hpiod is stopped
hpssd is stopped
[root@mandriva log]# /sbin/service hplip start
Starting hpiod: ./hpiod: error while loading shared libraries: libnetsnmp.so.10: cannot open shared object file: No such file or directory
                                                                [ÉCHEC ]
Starting hpssd:                                                 [  OK  ]
[root@mandriva log]#


une fois lancé, j'ai fait une page de test via CUPS et mon imprimante semble fonctionner correctement !


et :
2)
Lancement du service mandi : unable to open white list file
nl_bind_socket: No such file or directory
bind failed
unable to init netlink
unable to init "Interactive Firewall" plugin
                                                                [  OK  ]


mais là non plus je ne vois pas !



à part ça .....tout semble ok !
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
462
Starting hpiod: ./hpiod: error while loading shared libraries: libnetsnmp.so.10: cannot open shared object file: No such file or directory
                                                                [ÉCHEC ]


[redfox@mandriva ~]$ ls -l /usr/lib/libnetsnmp.*
-rwxr-xr-x 1 root root 820 2008-01-23 18:31 /usr/lib/libnetsnmp.la*
lrwxrwxrwx 1 root root 20 2008-05-17 20:58 /usr/lib/libnetsnmp.so -> libnetsnmp.so.15.1.0*
lrwxrwxrwx 1 root root 20 2008-05-17 20:46 /usr/lib/libnetsnmp.so.15 -> libnetsnmp.so.15.1.0*
-rwxr-xr-x 1 root root 664816 2008-01-23 18:31 /usr/lib/libnetsnmp.so.15.1.0*
[redfox@mandriva ~]$

je me colle un lien qui peut donner des idées !
https://bugs.launchpad.net/ubuntu/+source/hplip/+bug/132670


sinon, sympa la 2008.1 !
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
462
ok ! hplip semble résolu !

j'ai récupéré le paquet libnet-snmp10-5.3.1-7mdv2008.0.i586.rpm

ensuite :
 [root@mandriva Tarball]# rpm -Uvh libnet-snmp10-5.3.1-7mdv2008.0.i586.rpm
Préparation...              ########################################### [100%]
   1:libnet-snmp10          ########################################### [100%]
rpmdb: Page 82: bad page number 143
rpmdb: Page 82: invalid prev_pgno 150
rpmdb: /var/lib/rpm/Sigmd5: DB_VERIFY_BAD: Database verification failed
erreur: erreur db4(-30975) de db->verify: DB_VERIFY_BAD: Database verification failed
rpmdb: Page 122: bad page number 213
rpmdb: Page 145: bad page number 338
rpmdb: Page 145: invalid next_pgno 513
rpmdb: Page 179: partially zeroed page
rpmdb: /var/lib/rpm/Provideversion: DB_VERIFY_BAD: Database verification failed
erreur: erreur db4(-30975) de db->verify: DB_VERIFY_BAD: Database verification failed
rpmdb: Page 213: partially zeroed page
rpmdb: /var/lib/rpm/Requireversion: DB_VERIFY_BAD: Database verification failed
erreur: erreur db4(-30975) de db->verify: DB_VERIFY_BAD: Database verification failed
rpmdb: Page 457: bad page number 521
rpmdb: /var/lib/rpm/Providename: DB_VERIFY_BAD: Database verification failed
erreur: erreur db4(-30975) de db->verify: DB_VERIFY_BAD: Database verification failed
rpmdb: Page 602: bad prev_pgno 0 on overflow page (should be 96)
rpmdb: Page 602: overflow item incomplete
rpmdb: /var/lib/rpm/Requirename: DB_VERIFY_BAD: Database verification failed
erreur: erreur db4(-30975) de db->verify: DB_VERIFY_BAD: Database verification failed
rpmdb: Page 55: bad page number 130
rpmdb: Page 55: invalid prev_pgno 136
rpmdb: Page 55: invalid next_pgno 125
rpmdb: /var/lib/rpm/Name: DB_VERIFY_BAD: Database verification failed
erreur: erreur db4(-30975) de db->verify: DB_VERIFY_BAD: Database verification failed
[root@mandriva Tarball]# rpm -qa | grep snmp
net-snmp-utils-5.4.1-5mdv2008.1
libgsnmp0-0.2.0-3mdv2008.1
net-snmp-mibs-5.4.1-5mdv2008.1
erlang-snmp-R12B1-2mdv2008.1
net-snmp-5.4.1-5mdv2008.1
libnet-snmp-devel-5.4.1-5mdv2008.1
libnet-snmp15-5.4.1-5mdv2008.1
libnet-snmp10-5.3.1-7mdv2008.0
[root@mandriva Tarball]# /sbin/service hplip status
hpiod is stopped
hpssd is stopped
[root@mandriva Tarball]# /sbin/service hplip start
Starting hpiod:                                                 [  OK  ]
Starting hpssd:                                                 [  OK  ]
[root@mandriva Tarball]#
[root@mandriva Tarball]#


ta daa ! et voilà !


c'est ce que j'appelle un "passage en force" !

:-))
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
462
[root@mandriva Tarball]# rpm --rebuilddb
rpmdb: PANIC: fatal region error detected; run recovery
erreur: erreur db4(-30977) de dbenv->open: DB_RUNRECOVERY: Fatal error, run database recovery
erreur: ne peut ouvrir l'index Packages en utilisant db3 -  (-30977)
[root@mandriva Tarball]#

la solution semble-t-il :
# rm -f /var/lib/rpm/__db*
# db_verify /var/lib/rpm/Packages
# rpm --rebuilddb
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
462
j'ai pas trouvé la commande db_verify !

en cherchant j'ai trouvé le paquet db3-utils qui me propose la commande db3_verify !
malheureusement ça ne la pas fait en suivant ceci :
https://www.culte.org/listes/linux-31/2002-10/msg00044.html

enfin, sinon ceci marche très bien :
# rm -f /var/lib/rpm/__db*
# rpm --rebuilddb
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
462
en cherchant j'ai trouvé le paquet db3-utils qui me propose la commande db3_verify !

en fait la commande existe bien et se trouve ici :
/usr/lib/rpm/rpmdb_verify

et elle fonctionne très bien !
source : http://www.rpm.org/hintskinks/repairdb/

je crois que j'ai planté la base rpm depuis le passage à la 2008.1 ! :-(
j'ai systématiquement des problèmes avec urpmi et je dois reconstruire la base (ce qui dure des "plombes") !
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
462
réparer sa base rpm :

pour fixer
# rm -f /var/lib/rpm/__db.00*


sinon :

on fait une copie, au cas ou, du dossier /var/lib/rpm
# cd /var/lib 
# tar czvf /tmp/rpmdb.tar.gz rpm 


on vérifie l'intégrité :
# cd /var/lib/rpm
# /usr/lib/rpm/rpmdb_verify Packages


s'il n'y a pas d'erreur on répare :
# mv Packages Packages-ORIG
# /usr/lib/rpm/rpmdb_dump Packages-ORIG | /usr/lib/rpm/rpmdb_load Packages


on lit les headers dans Packages en faisant :
# rpm -qa


s'il n'y a pas de segfault on reconstruit les indices :
# rpm -vv --rebuilddb



on va bien voir ....
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
462
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
462
Re -

je poursuis avec le même message récurent :
Lancement du service mandi : unable to open white list file
nl_bind_socket: No such file or directory
bind failed
unable to init netlink
unable to init "Interactive Firewall" plugin
                                                                [  OK  ]


une "réponse" trouvée sur le net :

# chkconfig mandi off (unless you want the Interactive Firewall)

source : http://www.archivum.info/alt.os.linux.mandriva/2008-05/msg00716.html

......et pourquoi pas ?
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
462
un autre message récurrent :
[root@mandriva log]# cat prcsys.log
Activating Compat-mode for non LSB-script iptables
Activating Compat-mode for non LSB-script dccd
WARNING! Loop detected network -> resolvconf
 -> Ignoring requires resolvconf
Vérification de l'espace libre sur les partitions :             [  OK  ]
Lancement des services de gestion des ressources :              [  OK  ]
Lancement du verrouillage numérique :                           [  OK  ]
Lancement de atd :                                              [  OK  ]
Lancement du service acpi :                                     [  OK  ]
Lancement de irqbalance :                                       [  OK  ]
nvidia71xx (71.86.04-4mdv2008.1): Already installed on this kernel.
Le pilote ALSA (version 1.0.16) est déjà en marche.Restauration des réglages du mixer ALSA via alsactl :                                                       [  OK  ]
Démarrage de l'interface loopback :                             [  OK  ]
Activation de l'interface eth0 :                                [  OK  ]
Starting jexec servicesLancement de system logger :             [  OK  ]
Lancement de kernel logger :                                    [  OK  ]
Lancement de crond :                                            [  OK  ]
Lancement de resolvconf :                                       [  OK  ]
Attente de la mise en service du réseau                         [  OK  ]
Lancement du gestionnaire d'affichage :                         [  OK  ]
Lancement de fuse :                                             [  OK  ]
Montage des autres systèmes de fichiers :                       [  OK  ]
Chargement de la table des touches : fr-latin1                  [  OK  ]
La touche effacement (<-) envoie : ^?                           [  OK  ]
Lancement de xinetd                                             [  OK  ]
Lancement du bus de messages système :                          [  OK  ]
Lancement du service mandi : unable to open white list file
nl_bind_socket: No such file or directory
bind failed
unable to init netlink
unable to init "Interactive Firewall" plugin
                                                                [  OK  ]
Lancement du service Avahi :                                    [  OK  ]
Lancement de sshd :                                             [  OK  ]
Ajout du périphérique loopback à la table de routage...
Lancement du service d'impression CUPS :                        [  OK  ]
Lancement du service HAL :                                      [  OK  ]
Lancement de spamd :                                            [  OK  ]
Lancement du service de courrier Postfix :                      [  OK  ]
Starting fail2ban:                                              [  OK  ]
Total time: 24 seconds
[root@mandriva log]#


des explications techniques ici : https://qa.mandriva.com/show_bug.cgi?id=41058