Passer d"un chiffre décimal à un entier avec [Résolu/Fermé]

Signaler
-
 Kristoch91 -
Bonjour,

J'aimerai passer une de mes variable de décimale en entier (49.5236=>49).
Ma variable est le résultat d'un calcul que j'afficherais dans une phrase par la suite.

quelqu'un aurait une idée de la ligne de code que je pourrais appliquer ?
J'utilise excel 2000

merci d'avance

3 réponses

Messages postés
433
Date d'inscription
dimanche 17 février 2008
Statut
Membre
Dernière intervention
17 octobre 2008
301
Bonjour,
la fonction Excel =ENT(A1) arrondit à l'entier inférieur.
en vba excel : maVariable = Int(maVariable)
I.
merci pour cette info

il n'y aurait pas pour l'entier le plus proche?
Messages postés
433
Date d'inscription
dimanche 17 février 2008
Statut
Membre
Dernière intervention
17 octobre 2008
301
ben si.
Excel : =ARRONDI(A1;0) 0 correspondant au nombre de décimales
en vba excel : maVariable = Round(maVariable)
I.
Merci pour ton aide