Excel-Somme selon une condition??

Résolu/Fermé
smod329 Messages postés 1 Date d'inscription samedi 19 avril 2008 Statut Membre Dernière intervention 19 avril 2008 - 19 avril 2008 à 20:49
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 - 20 avril 2008 à 07:59
Bonjour,

voila j'ai un devor à faire pour l'iut mais je n'arrive pas à faire la somme de plusieurs nombre d'une meme colonne selon un critère.


J'ai attribué de numéro à des acteurs de cinéma ds la colonne B et dans la C, j'ai mis le rang qu'il avait dans le film cad s'il avait le 1er, 2eme, ou 3eme roles.

Dans la colonne A se trouve le n° du film.

Et la meme chose pour 40 films.

J'aimerai aditionner le rang des acteurs en fonction des acteurs.

Comment dois je faire? Merci

voici ma feuille de calcul:

A B C D
NumFilm NumActeur Rang Sexe
10 1 3 M
28 2 3 M
24 3 1 F
7 3 3 F
39 3 1 F
16 4 1 M
16 5 2 M
26 6 1 M
36 7 1 M
29 8 2 M
19 9 1 M
35 10 3 M
8 11 3 F
37 12 1 F
29 13 3 F
31 13 2 F
40 13 3 F

J'aimerai pouvoir remplir ce tableau à l'aide de votre solution

Répartition par acteur
Nom acteur ZETA-JONES
Numéro acteur dans la base 13
A joué dans 3 films
Rang moyen ?
A voir également:

4 réponses

medbo Messages postés 551 Date d'inscription lundi 18 avril 2005 Statut Membre Dernière intervention 24 mars 2019 29
19 avril 2008 à 20:55
tu utilise la formule "somme.si" ou "sommeprod"
0
Utilisateur anonyme
19 avril 2008 à 20:56
Bonsoir,

Si ce que tu souhaites est obtenir le rang moyen, pourquoi ne pas utiliser simplement la fonction MOYENNE ? Elle s'utilise comme la fonction SOMME.
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 393
20 avril 2008 à 07:59
Bonjour
N° Acteur, colonne B rang colonne C
Utilisez la formule, pour ligne de 2 à 100:
=SOMME.SI(B2:C100;N° acteur;C2:C100)/NB.SI(C2:C200;N°D'Acteur)
Ca devrait marcher, vous pouvez toutefois réduire cette formule si vous avez déja calculé quelque part le nombre de film où a joué l'acteur, en nremplaçant la partie NB.SI.... par l'adresse de la cellule où se trouve se résultat
Bonne chance
CRDLMNT
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 393
20 avril 2008 à 07:59
Bonjour
N° Acteur, colonne B rang colonne C
Utilisez la formule, pour ligne de 2 à 100:
=SOMME.SI(B2:C100;N° acteur;C2:C100)/NB.SI(C2:C200;N°D'Acteur)
Ca devrait marcher, vous pouvez toutefois réduire cette formule si vous avez déja calculé quelque part le nombre de film où a joué l'acteur, en remplaçant la partie NB.SI.... par l'adresse de la cellule où se trouve se résultat
Bonne chance
CRDLMNT
0