Equation : ax²+bx+c=0 sur excel

Résolu/Fermé
interlocuteur - 11 mars 2008 à 14:37
 hichem - 14 févr. 2010 à 18:02
Bonjour,je voudrais soivoir comment résoudre une equation de deusiéme degré ax²+bx+c=0 sur excel ; en utilison =si(valeur si vrais; valeur si faux )! s'il vous plait j'ai besoin d'aide! une réponse détaillé s'il vous plais .

4 réponses

Raymond PENTIER Messages postés 56843 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 30 novembre 2022 17 181
12 mars 2008 à 12:09
Méthode graphique :

Colonne A pour les valeurs de x. Tu peux commencer par -1000, puis -900 et continuer l'incrémentation jusqu'à 1000, soit 21 lignes (de 2 à 22). Colonne B pour les valeurs de y =a*x*x+b*x+c (en remplaçant a, b et c par leurs valeurs) que tu recopies vers le bas (de 2 à 22).
Puis tu sélectionnes A1:B22 et tu fais ton graphique en "nuage de points".
Si ta parabole ne coupe pas l'axe des x (abcisses), il n'y a aucune solution.
Si elle est tangente à l'axe des x, il y a une seule solution.
Si elle le coupe, les solutions sont les valeurs de x aux points d'intersection.
Tu peux alors revenir dans ta grille de saisie et choisir des valeurs de x non plus de -1000 à 1000, mais plus proches des 2 solutions et avec des intervalles plus petits (tu fais ainsi un zoom de ton graphique sur la zone intéressante).

Méthode avec SI :

Tu fais le même tableau et dans la cellule C3 tu écris =SI((B2-B3)*(B3-B4)<0;"c'est par ici";"") et tu recopies jusqu'à C21. Si tu obtiens 2 fois "c'est par ici" c'est qu'il y a 2 solutions, et tu procèdes comme précédemment (valeurs de x plus proches et intervalles plus petits).

Méthode algébrique (et pourquoi chercher à faire autrement ?) :
Tu saisis les valeurs de a, b et c dans les cellules A1, B1 et C1.
Tu saisis en E1 =B1*B1-4*A1*C1 ,
........... en F1 =SI(E1<0;"pas de solution";(-B1+RACINE(E1))/2*A1)
....... et en G1 =SI(E1<0;"pas de solution";(-B1-RACINE(E1))/2*A1)

Mais tu peux tester les 3 façons de procéder ...
13
Merci pour la formule sur excell pour résoudre l'equation, mais j'ai longtemps cherché car ça ne marchait pas chez moi, en fait il manque une parenthèse pour diviser -B1+RACINE(E1) par 2*A1, il faut ajouter les parenthèses à 2*A1, donc ecrire (-B1+RACINE(E1)/(2A1))
0
Raymond PENTIER Messages postés 56843 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 30 novembre 2022 17 181 > michel
12 oct. 2008 à 14:34
Tu as (presque) raison ! Il faut effectivement mettre le dénominateur 2*A1 entre parenthèses, sinon Excel multiplie (-B1+RACINE(E1))/2 par A1.
Du coup tu as oublié une parenthèse au numérateur : C'est bien (-B1+RACINE(E1)) qu'il faut diviser par (2*A1).
La formule correcte est donc : = ( -B1+RACINE(E1) ) / (2*A1)
Merci de ton intervention, et mes excuses à ceux qui ont tenté d'utiliser ma formule ....
0
michel > Raymond PENTIER Messages postés 56843 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 30 novembre 2022
12 oct. 2008 à 18:17
OK, merci, tout rentre dans l'ordre, c'était la remière fois que je me lançait sur un forum, j'avoue que c'est assez amusant, je suis moi aussi retraité, c'est pourquoi je ne suis pas très aguerri à ce mode de loisir : à bientôt peut-être.
0
mister3d Messages postés 297 Date d'inscription samedi 20 janvier 2007 Statut Membre Dernière intervention 21 avril 2021 22
11 mars 2008 à 14:43
bonjour,

l'idéal est de faire ca en plusieurs cellules:

tu prends 3 cellules, pour les valeurs a, b et c.
tu prend une 4eme cellule ou tu fait ton test b²-4ac. sica marche, tu rajoute un SI() devant et le tour est joué!

++
bon courage!
6
la reponc et delta=b2-4ac
4
comment trouver l'algorithme de cette inéquation?
1
Raymond PENTIER Messages postés 56843 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 30 novembre 2022 17 181
17 mars 2008 à 02:46
il est trouvé !
0
arrial Messages postés 1745 Date d'inscription mardi 11 mars 2008 Statut Membre Dernière intervention 22 mai 2017 249
21 mars 2008 à 11:18
Pour aller vite :

deuxième de gré => deux racines max

=> tracer le graphe > répérer approximativement les zéros > affiner avec l'outil "VALEUR CIBLE" en proposant successivement les approx. en x.
0