Echec du démarrage de bind9

Résolu/Fermé
s0s0 Messages postés 18 Date d'inscription mardi 15 janvier 2008 Statut Membre Dernière intervention 16 juin 2008 - 1 mars 2008 à 10:22
lami20j Messages postés 21331 Date d'inscription jeudi 4 novembre 2004 Statut Modérateur, Contributeur sécurité Dernière intervention 30 octobre 2019 - 1 mars 2008 à 19:29
Bonjour,

Je suis sur ubuntu, et je veux faire un DNS avec bind9. J'ai créé mes fichiers de zone maitre et zone esclave, sauf que quand je fais /etc/init.d/bind9 start, il me met : starting domain name service ... bind [fail]
et quand je fait /etc/init.d.bind9 reload , il me met rndc : connect failed : 127.0.0.1#953: connection refused [fail].

j'ai cherché pour essayer de trouver les erreurs, en vérifiant la clé, quand je tape : /usr/sbin/rndc-confgen , j'ai une clé de rndc qui n'est pas la même que celle qui est dans /etc/bind/rndc.key, alors j'ai remplacé la clé qui était dans /etc/rndc.key par celle qui était dans /usr/sbin/rndc-confgen, puis quand je relance bind9, ça n'a rien changé, il me met toujours connection refused [fail].

Est ce que vous pouvez m'aider svp !!! Je suis complétement perdue.

Merci de votre aide .

4 réponses

lami20j Messages postés 21331 Date d'inscription jeudi 4 novembre 2004 Statut Modérateur, Contributeur sécurité Dernière intervention 30 octobre 2019 3 566
1 mars 2008 à 10:28
Salut,

essaie à nouveau et puis regarde dans /var/log/syslog
pour faire cela ouvre 2 consoles
dans la 1ère tu tapes
sudo tail -f /var/log/syslog
dans la 2ème tu tapes
sudo /etc/init.d/bind9 reload
et tu retournes dans la 1ère pour voir les logs
5
s0s0 Messages postés 18 Date d'inscription mardi 15 janvier 2008 Statut Membre Dernière intervention 16 juin 2008
1 mars 2008 à 10:44
salut,
Merci pour ton aide, alors j'ai fais ce que tu m'as dit de faire. Quand je tape sudo tail -f /var/log/syslog dans la première fenetre et que dans la deuxième je tape : sudo /etc/init.d/bind9 reload

La première fenetre me dit :

Mar 1 10:12:00 administrateur named [8820] : existing (due to fatal error)
Mar 1 10:17:01 administrateur /USR/SBIN/CRON[8845]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Mar 1 10:30:03 administrateur --MARK--
Mar 1 10:31:23 administrateur kernel: [2520.271814] Failure registering capabilities with primary security module
Mar 1 10:31:23 administrateur named [8998]: starting BIND 9.4.1-P1 -u bind
Mar 1 10:31:23 administrateur named [8998]: found 1 CPU, using 1 worker thread
Mar 1 10:31:23 administrateur named [8998]: loading configuration from '/etc/bind/named.conf'
Mar 1 10:31:23 administrateur named [8998]: /etc/bind/named.conf:64: missing ';' before 'include'
Mar 1 10:31:23 administrateur named [8998]: loading configuration: failure
Mar 1 10:31:23 administrateur named [8998]: exiting (due fatal error)

puis que je suis partie regarder dans named.conf, et j'ai mis le ';' , ensuite je l'ai relancé sudo /etc/init.d/bind9 reload il me met toujours connection refused [fail] et quand je relance sudo tail -f /var/log/syslog il me met le même message, alors que j'ai déjà modifié.
0
lami20j Messages postés 21331 Date d'inscription jeudi 4 novembre 2004 Statut Modérateur, Contributeur sécurité Dernière intervention 30 octobre 2019 3 566
1 mars 2008 à 10:58
Re,

affiche ton fichier de configuration
0
s0s0 Messages postés 18 Date d'inscription mardi 15 janvier 2008 Statut Membre Dernière intervention 16 juin 2008
1 mars 2008 à 11:36
re ,

voici le fichier de named.conf :

// This is the primary configuration file for the BIND DNS server named.
//
// Please read /usr/share/doc/bind9/README.Debian.gz for information on the
// structure of BIND configuration files in Debian, *BEFORE* you customize
// this configuration file.
//
// If you are just adding zones, please do that in /etc/bind/named.conf.local

include "/etc/bind/named.conf.options";

// prime the server with knowledge of the root servers
zone "." {
type hint;
file "/etc/bind/db.root";
};

// be authoritative for the localhost forward and reverse zones, and for
// broadcast zones as per RFC 1912

zone "localhost" {
type master;
file "/etc/bind/db.local";
};

zone "127.in-addr.arpa" {
type master;
file "/etc/bind/db.127";
};

zone "0.in-addr.arpa" {
type master;
file "/etc/bind/db.0";
};

zone "255.in-addr.arpa" {
type master;
file "/etc/bind/db.255";
};

//zone maitre
zone "mondomaine.fr" {
type master;
file "/etc/bind/db.mondomaine";
};

//zone esclave
zone "1.168.192.in-addr.arpa" {
type master;
file "/etc/bind/db.1.168.192";
};
// zone "com" { type delegation-only; };
// zone "net" { type delegation-only; };

// From the release notes:
// Because many of our users are uncomfortable receiving undelegated answers
// from root or top level domains, other than a few for whom that behaviour
// has been trusted and expected for quite some length of time, we have now
// introduced the "root-delegations-only" feature which applies delegation-only
// logic to all top level domains, and to the root domain. An exception list
// should be specified, including "MUSEUM" and "DE", and any other top level
// domains from whom undelegated responses are expected and trusted.
// root-delegation-only exclude { "DE"; "MUSEUM"; };

include "/etc/bind/named.conf.local";
0
s0s0 Messages postés 18 Date d'inscription mardi 15 janvier 2008 Statut Membre Dernière intervention 16 juin 2008
1 mars 2008 à 19:16
re,

bah miraculeusement, ça marche maintenant .... lol alors que je n'ai touché à rien, j'ai juste redémarré le pc.

Merci beaucoup de ton aide ...
0
lami20j Messages postés 21331 Date d'inscription jeudi 4 novembre 2004 Statut Modérateur, Contributeur sécurité Dernière intervention 30 octobre 2019 3 566
1 mars 2008 à 19:29
Re,

de rien ;-)

qui ne crois pas aux miracles, n'est pas réaliste ;-)
0