Prob paquet debian

Fermé
grandfroid Messages postés 3 Date d'inscription vendredi 15 février 2008 Statut Membre Dernière intervention 21 février 2008 - 20 févr. 2008 à 11:41
grandfroid Messages postés 3 Date d'inscription vendredi 15 février 2008 Statut Membre Dernière intervention 21 février 2008 - 20 févr. 2008 à 17:12
Bonjour,
Sur un serveur Debian Etch j'ai un paquet cassé, il s'agit de zlib1g, il entre en conflit avec tzdata,
ces 2 paquets me sont indispensables et il m'est impossible de les désinstaller car ils supprimeraient plein d'autre dépendance, dont apache2 mysql etc (pas top pour un serveur en prod)
j'ai essayé 1 dpkg -confugure zlib1g
il me dit qu'il ne peut pas configurer le paquet car il dépend de libc6 >= 2.7-1

je télécharge le .deb libc6 demandé et lors de son installation il me dit qu'il dépend d'autre librairie, et ainsi de suite j etente de tout mettre à jour et résultat tous les paquets que j'ai tenté de réinstallé on t maintenant le statut de broken.

merci pour votre aide

2 réponses

jeanbi Messages postés 15118 Date d'inscription samedi 9 décembre 2006 Statut Contributeur Dernière intervention 6 février 2023 2 181
20 févr. 2008 à 11:46
bonjour,
as tu fait une mise à jour
si les paquets entre en conflit c'est que les versions differes et non qu'il est casse , .
a+

grandfroid Messages postés 3 Date d'inscription vendredi 15 février 2008 Statut Membre Dernière intervention 21 février 2008
20 févr. 2008 à 17:12
hello
oui il ne me laisse pas faire de mise à jour car des paquet sont cassés, il me demande de faire un apt-get update -f
le problème est le même qu'avant car il voudrait supprimer une longue liste de paquet