Besoins de traduire cest script en perl svp [Résolu/Fermé]

Signaler
Messages postés
11
Date d'inscription
vendredi 1 février 2008
Statut
Membre
Dernière intervention
3 mars 2008
-
Messages postés
29267
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
30 juillet 2020
-
Bonjour,
je debute en perl est ce que quelqun un pourrait me traduire les scripts suivant?

Saisir le Numéros de bureau.
Recherche dans netmap.txt si le bureau existe et si des adresses Mac sont présentes dans ce bureau si il y en a alors
recherche dans téléphone.txt pour savoir à quel nurémos de tel elle correspondent


Tab netmap: structure
switch: Chaine
numport : entier
bureau : chaine
.....
adressemac :chaine
FINSTRUCTUR

Tab téléphone: structure
numtel:chaine
identité : chaine
adressemac: chaine
....
FINSTRUCTURE

Var téléphone tableau [1...X] de téléphone
Var netmap tableau [1...X] de netmap

Procédure RECHERCHE(d:netmap [1...X], téléphone[1...X], nom chaine)
Variable i,j :entier
Variable mac,bureau :chaine

Debut
Ouvrir(netmap.txt, L)
Ouvrir(téléphone.txt, L)
Saisir bureau
i <- 1
j <- 1
Tant que j < X et bureau <>netmap[ i ].bureau

j <- j+1

Fintantque

Si bureau = netmap[ j ].bureau alors
mac <- netmap[ j ].mac
Finsi

Tant que i < X et mac <>téléphone[ i ].mac alors
i <- i+1
FinTantQue

Si mac=téléphone[ i ].mac alors
Afficher( téléphone[ i ].numtel, netmap[ j ].bureau)
FinSi

Fermer(netmap.txt)
Fermer(téléphone.txt)
Fin




Procédure RECHERCHE()
Variable bureau1,bureau2, adresse1, adresse2 :chaine

Debut
Ouvrir(netmap.txt, L)
Ouvrir(téléphone.txt, L)

{initialiser chaines vide}
bureau1 <- ""
bureau2 <- ""

{saisir bureau1, chaine vide non admise}
Tantque bureau1=""
Saisir bureau1
Fin Tantque

{lire sequentiellement le fichier netmap.txt}
{on arrête de lire les fichier si on a atteint la fin du fichier ou si bureau1=bureau2}
Tant que (non (FinFichier netmap.txt)) ou (non (bureau1=bureau2))
Lire netmap.txt -> netmap
bureau2 <- netmap.bureau
adresse1 <- netmap.adressemac
Fintantque
Fermer(netmap.txt)

Si bureau1 = bureau2 alors
debut
adresse2 <- ""
{lire sequentiellement le fichier téléphone.txt}
{on arrête de lire les fichier si on a atteint la fin du fichier ou si adresse1=adresse2}
Tant que (non (FinFichier téléphone.txt)) ou (non (adresse1=adresse2))
Lire téléphone.txt -> téléphone
adresse2 <- téléphone.adressemac
Fintantque
Fermer(téléphone.txt)
Afficher(téléphone.numtel, netmap.bureau)
fin
sinon
Afficher("Ce bureau n'existe pas")
FinSi

Fin

1 réponse

Messages postés
29267
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
30 juillet 2020
6 898
Je pense que tu devrais lire un tutoriel en perl pour apprendre à manipuler des fichiers :
http://perl.developpez.com/tutoriel/cours3/

Bonne chance