No manual entry for <commande>

Résolu
Bonjour,

Je viens d'installer ubuntu et je fais un peu de programme en C (débutant).

Quand je tape man fprintf, il m'affiche No manual entry for fprintf.

Si quelqu'un peut m'aider, ce serait avec plaisir merci..
--

demadez et l'on vous répondra, cherchez et vous trouverez, frappez et l'on vous ouvrira.
Configuration: Linux
Firefox 2.0.0.11

15 réponses

  1. Salut,

    Tu as bien descendu les packages GCC et G++ ?
    1. Modérateur
      Salut,

      l'installation de gcc et g++ n'installe pas la doc
      Voici la liste des pages man contenu par manpages-dev ;-)
    2. @lami20jouaip autant pour moi... j'ai encore tapé trop vite et oublié la moitié des mots....

      Je m'auto-flagèle pour la peine :-))))
  2. voici le résultat après sudo aptitude install manpages-dev

    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    Lecture de l'information d'état étendu
    Initialisation de l'état des paquets... Fait
    Écriture de l'information d'état étendu... Fait
    Construction de la base de données des étiquettes... Fait
    Les paquets partiellement installés suivants seront configurés :
    amavisd-new mnogosearch-common mtop nanourl newpki-server nuauth nuauth-log-mysql
    0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
    Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 0o seront utilisés.
    Écriture de l'information d'état étendu... Fait
    Paramétrage de newpki-server (2.0.0+rc1-8) ...
    Starting NewPKI: newpki-serverinvoke-rc.d: initscript newpki-server, action "start" failed.
    dpkg : erreur de traitement de newpki-server (--configure) :
    le sous-processus post-installation script a retourné une erreur de sortie d'état 1
    Paramétrage de nuauth (2.2.4-1) ...
    chown: ne peut accéder `/var/run/nuauth/': Aucun fichier ou répertoire de ce type
    dpkg : erreur de traitement de nuauth (--configure) :
    le sous-processus post-installation script a retourné une erreur de sortie d'état 1
    Paramétrage de mnogosearch-common (3.2.41-2) ...
    Le message n° 1 de /var/lib/dpkg/info/mnogosearch-common.templates ne contient pas de ligne « Template: »
    dpkg : erreur de traitement de mnogosearch-common (--configure) :
    le sous-processus post-installation script a retourné une erreur de sortie d'état 9
    Paramétrage de mtop (0.6.6-1.2) ...
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    dpkg : erreur de traitement de mtop (--configure) :
    le sous-processus post-installation script a retourné une erreur de sortie d'état 1
    Paramétrage de nanourl (0.1-7.1) ...
    ln: création d'un lien symbolique `/etc/apache/conf.d/nanourl' vers `/etc/nanourl/apache.conf': Le fichier existe.
    dpkg : erreur de traitement de nanourl (--configure) :
    le sous-processus post-installation script a retourné une erreur de sortie d'état 1
    dpkg : des problèmes de dépendances empêchent la configuration de nuauth-log-mysql :
    nuauth-log-mysql dépend de nuauth ; cependant :
    Le paquet nuauth n'est pas encore configuré.
    dpkg : erreur de traitement de nuauth-log-mysql (--configure) :
    problèmes de dépendances - laissé non configuré
    Paramétrage de amavisd-new (1:2.4.2-6.2ubuntu1) ...
    Creating/updating amavis user account...
    Starting amavisd: head: Ne peut ouvrir `/etc/mailname' en lecture: Aucun fichier ou répertoire de ce type
    The value of variable $myhostname is "PC2JA", but should have been
    a fully qualified domain name; perhaps uname(3) did not provide such.
    You must explicitly assign a FQDN of this host to variable $myhostname
    in /etc/amavis/conf.d/05-node_id, or fix what uname(3) provides as a host's
    network name!
    (failed).
    invoke-rc.d: initscript amavis, action "start" failed.
    dpkg : erreur de traitement de amavisd-new (--configure) :
    le sous-processus post-installation script a retourné une erreur de sortie d'état 1
    Des erreurs ont été rencontrées pendant l'exécution :
    newpki-server
    nuauth
    mnogosearch-common
    mtop
    nanourl
    nuauth-log-mysql
    amavisd-new
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Échec de l'installation d'un paquet. Tentative de réparation :
    Paramétrage de nanourl (0.1-7.1) ...
    ln: création d'un lien symbolique `/etc/apache/conf.d/nanourl' vers `/etc/nanourl/apache.conf': Le fichier existe.
    dpkg : erreur de traitement de nanourl (--configure) :
    le sous-processus post-installation script a retourné une erreur de sortie d'état 1
    Paramétrage de mtop (0.6.6-1.2) ...
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    dpkg : erreur de traitement de mtop (--configure) :
    le sous-processus post-installation script a retourné une erreur de sortie d'état 1
    Paramétrage de nuauth (2.2.4-1) ...
    chown: ne peut accéder `/var/run/nuauth/': Aucun fichier ou répertoire de ce type
    dpkg : erreur de traitement de nuauth (--configure) :
    le sous-processus post-installation script a retourné une erreur de sortie d'état 1
    Paramétrage de mnogosearch-common (3.2.41-2) ...
    Le message n° 1 de /var/lib/dpkg/info/mnogosearch-common.templates ne contient pas de ligne « Template: »
    dpkg : erreur de traitement de mnogosearch-common (--configure) :
    le sous-processus post-installation script a retourné une erreur de sortie d'état 9
    Paramétrage de newpki-server (2.0.0+rc1-8) ...
    Starting NewPKI: newpki-serverinvoke-rc.d: initscript newpki-server, action "start" failed.
    dpkg : erreur de traitement de newpki-server (--configure) :
    le sous-processus post-installation script a retourné une erreur de sortie d'état 1
    dpkg : des problèmes de dépendances empêchent la configuration de nuauth-log-mysql :
    nuauth-log-mysql dépend de nuauth ; cependant :
    Le paquet nuauth n'est pas encore configuré.
    dpkg : erreur de traitement de nuauth-log-mysql (--configure) :
    problèmes de dépendances - laissé non configuré
    Paramétrage de amavisd-new (1:2.4.2-6.2ubuntu1) ...
    Creating/updating amavis user account...
    Starting amavisd: head: Ne peut ouvrir `/etc/mailname' en lecture: Aucun fichier ou répertoire de ce type
    The value of variable $myhostname is "PC2JA", but should have been
    a fully qualified domain name; perhaps uname(3) did not provide such.
    You must explicitly assign a FQDN of this host to variable $myhostname
    in /etc/amavis/conf.d/05-node_id, or fix what uname(3) provides as a host's
    network name!
    (failed).
    invoke-rc.d: initscript amavis, action "start" failed.
    dpkg : erreur de traitement de amavisd-new (--configure) :
    le sous-processus post-installation script a retourné une erreur de sortie d'état 1
    Des erreurs ont été rencontrées pendant l'exécution :
    nanourl
    mtop
    nuauth
    mnogosearch-common
    newpki-server
    nuauth-log-mysql
    amavisd-new
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    Lecture de l'information d'état étendu
    Initialisation de l'état des paquets... Fait
    Construction de la base de données des étiquettes... Fait


    Remarques qu'il y a plusieurs erreusrs à la quinzième ligne à partir du bàs.

    Comment le résoudre?

    demadez et l'on vous répondra, cherchez et vous trouverez, frappez et l'on vous ouvrira.
    1. Question de Arnaud00. :

      Salut,

      Tu as bien descendu les packages GCC et G++ ?


      Réponse :

      Je ne sais pas trop. Est-ce que je peux aller dans Synaptic et dans ce cas j'installe gcc et g++ ?
      demadez et l'on vous répondra, cherchez et vous trouverez, frappez et l'on vous ouvrira.
      1. Oui dans synaptic dans la section documentation il faudrait que tu installes le package mapage-fr-dev
        1. RE :
          Oui dans synaptic dans la section documentation il faudrait que tu installes le package mapage-fr-dev


          il n'y a aucun paquet qui s'appelle mapage-fr-dev dans synaptic à moins que j'ai mal compris?

          demadez et l'on vous répondra, cherchez et vous trouverez, frappez et l'on vous ouvrira.
          1. Je devrais arrêter de faire plusieurs choses à la fois.... Le package qu'il te faut installé est manpages-fr-dev !!!

            manpages comme manual pages...

            Désolé ....
            1. j'ai fais le code sudo aptitude install manpages-fr-dev et voici quelques erreurs rencontrées parmi tan d'autres :

              ... invoke-rc.d: initscript amavis, action "start" failed.
              dpkg : erreur de traitement de amavisd-new (--configure) :
              le sous-processus post-installation script a retourné une erreur de sortie d'état 1
              Des erreurs ont été rencontrées pendant l'exécution :
              nanourl
              mtop
              nuauth
              mnogosearch-common
              newpki-server
              nuauth-log-mysql
              amavisd-new
              Lecture des listes de paquets... Fait
              ....


              C'est quoi qui bloque?

              demadez et l'on vous répondra, cherchez et vous trouverez, frappez et l'on vous ouvrira.
              1. Tu charges tes paquets depuis un CD ou directement depuis le net ?
                1. comme je suis débutant, je croyais que le cd faisait la même mise à jour que sur le net.

                  je n'utilise plus de cd mais dès fois synaptiqc me demande d'insérer le cd ... peux-tu m'éclaircir à ce sujet? Dois-je

                  me'abstenir l'utilisation du cd ou bien se fier sur les sources du net?

                  demadez et l'on vous répondra, cherchez et vous trouverez, frappez et l'on vous ouvrira.
              2. Modérateur
                Salut,

                affiche
                cat /etc/apt/sources.list
                si tu tapes
                sudo aptitude update
                tu as quoi comme message d'erreur?
                1. code

                  cat /etc/apt/sources.list

                  Voici le résultat :

                  # deb cdrom:[Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016)]/ gutsy main restricted
                  # See https://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
                  # newer versions of the distribution.

                  # Line commented out by installer because it failed to verify:
                  # deb http://fr.archive.ubuntu.com/ubuntu/ gutsy main restricted
                  # Line commented out by installer because it failed to verify:
                  # deb-src http://fr.archive.ubuntu.com/ubuntu/ gutsy main restricted

                  ## Major bug fix updates produced after the final release of the
                  ## distribution.
                  # Line commented out by installer because it failed to verify:
                  # deb http://fr.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted
                  # Line commented out by installer because it failed to verify:
                  # deb-src http://fr.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted

                  ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
                  ## team, and may not be under a free licence. Please satisfy yourself as to
                  ## your rights to use the software. Also, please note that software in
                  ## universe WILL NOT receive any review or updates from the Ubuntu security
                  ## team.
                  # Line commented out by installer because it failed to verify:
                  # deb http://fr.archive.ubuntu.com/ubuntu/ gutsy universe
                  # Line commented out by installer because it failed to verify:
                  # deb-src http://fr.archive.ubuntu.com/ubuntu/ gutsy universe
                  # Line commented out by installer because it failed to verify:
                  # deb http://fr.archive.ubuntu.com/ubuntu/ gutsy-updates universe
                  # Line commented out by installer because it failed to verify:
                  # deb-src http://fr.archive.ubuntu.com/ubuntu/ gutsy-updates universe

                  ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
                  ## team, and may not be under a free licence. Please satisfy yourself as to
                  ## your rights to use the software. Also, please note that software in
                  ## multiverse WILL NOT receive any review or updates from the Ubuntu
                  ## security team.
                  # Line commented out by installer because it failed to verify:
                  # deb http://fr.archive.ubuntu.com/ubuntu/ gutsy multiverse
                  # Line commented out by installer because it failed to verify:
                  # deb-src http://fr.archive.ubuntu.com/ubuntu/ gutsy multiverse
                  # Line commented out by installer because it failed to verify:
                  # deb http://fr.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse
                  # Line commented out by installer because it failed to verify:
                  # deb-src http://fr.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse

                  ## Uncomment the following two lines to add software from the 'backports'
                  ## repository.
                  ## N.B. software from this repository may not have been tested as
                  ## extensively as that contained in the main release, although it includes
                  ## newer versions of some applications which may provide useful features.
                  ## Also, please note that software in backports WILL NOT receive any review
                  ## or updates from the Ubuntu security team.
                  # deb http://fr.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse
                  # deb-src http://fr.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse

                  ## Uncomment the following two lines to add software from Canonical's
                  ## 'partner' repository. This software is not part of Ubuntu, but is
                  ## offered by Canonical and the respective vendors as a service to Ubuntu
                  ## users.
                  deb http://archive.canonical.com/ubuntu/ gutsy partner
                  deb-src http://archive.canonical.com/ubuntu/ gutsy partner

                  # Line commented out by installer because it failed to verify:
                  # deb http://security.ubuntu.com/ubuntu/ gutsy-security main restricted
                  # Line commented out by installer because it failed to verify:
                  # deb-src http://security.ubuntu.com/ubuntu/ gutsy-security main restricted
                  # Line commented out by installer because it failed to verify:
                  # deb http://security.ubuntu.com/ubuntu/ gutsy-security universe
                  # Line commented out by installer because it failed to verify:
                  # deb-src http://security.ubuntu.com/ubuntu/ gutsy-security universe
                  # Line commented out by installer because it failed to verify:
                  # deb http://security.ubuntu.com/ubuntu/ gutsy-security multiverse
                  # Line commented out by installer because it failed to verify:
                  deb http://fr.archive.ubuntu.com/ubuntu/ gutsy main universe multiverse
                  deb-src http://fr.archive.ubuntu.com/ubuntu/ gutsy universe main multiverse #Added by software-properties
                  # deb-src http://security.ubuntu.com/ubuntu/ gutsy-security multiverse
                  # deb cdrom:[Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016)]/ gutsy main restricted
                  deb http://security.ubuntu.com/ubuntu/ gutsy-security universe main multiverse
                  deb-src http://fr.archive.ubuntu.com/ubuntu/ gutsy-security universe main multiverse
                  deb http://fr.archive.ubuntu.com/ubuntu/ gutsy-updates universe main multiverse
                  deb-src http://fr.archive.ubuntu.com/ubuntu/ gutsy-updates universe main multiverse
                  # deb cdrom:[Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016)]/ gutsy main restricted
                  deb http://apt.tt-solutions.com/ubuntu/ etch main


                  Je n'y comprend rien, il y a trop d'erreurs.

                  demadez et l'on vous répondra, cherchez et vous trouverez, frappez et l'on vous ouvrira.
                2. code :

                  sudo aptitude update

                  Résultat :

                  Prendre :1 http://fr.archive.ubuntu.com gutsy Release.gpg [191B]
                  Atteint http://fr.archive.ubuntu.com gutsy/main Translation-fr
                  Prendre :2 https://ubuntu.com/security/notices gutsy-security Release.gpg [191B]
                  Ign https://ubuntu.com/security/notices gutsy-security/universe Translation-fr
                  Prendre :3 http://archive.canonical.com gutsy Release.gpg [191B]
                  Ign http://archive.canonical.com gutsy/partner Translation-fr
                  Ign https://ubuntu.com/security/notices gutsy-security/main Translation-fr
                  Ign https://ubuntu.com/security/notices gutsy-security/multiverse Translation-fr
                  Atteint https://ubuntu.com/security/notices gutsy-security Release
                  Atteint http://archive.canonical.com gutsy Release
                  Atteint http://fr.archive.ubuntu.com gutsy/universe Translation-fr
                  Atteint https://ubuntu.com/security/notices gutsy-security/universe Packages
                  Atteint http://archive.canonical.com gutsy/partner Packages
                  Atteint https://ubuntu.com/security/notices gutsy-security/main Packages
                  Atteint https://ubuntu.com/security/notices gutsy-security/multiverse Packages
                  Atteint http://archive.canonical.com gutsy/partner Sources
                  Ign http://apt.tt-solutions.com etch Release.gpg
                  Atteint http://fr.archive.ubuntu.com gutsy/multiverse Translation-fr
                  Prendre :4 http://fr.archive.ubuntu.com gutsy-security Release.gpg [191B]
                  Ign http://apt.tt-solutions.com etch/main Translation-fr
                  Prendre :5 http://fr.archive.ubuntu.com gutsy-updates Release.gpg [191B]
                  Ign http://fr.archive.ubuntu.com gutsy-updates/universe Translation-fr
                  Ign http://fr.archive.ubuntu.com gutsy-updates/main Translation-fr
                  Ign http://fr.archive.ubuntu.com gutsy-updates/multiverse Translation-fr
                  Atteint http://fr.archive.ubuntu.com gutsy Release
                  Atteint http://fr.archive.ubuntu.com gutsy-security Release
                  Atteint http://fr.archive.ubuntu.com gutsy-updates Release
                  Ign http://apt.tt-solutions.com etch Release
                  Atteint http://fr.archive.ubuntu.com gutsy/main Packages
                  Atteint http://fr.archive.ubuntu.com gutsy/universe Packages
                  Atteint http://fr.archive.ubuntu.com gutsy/multiverse Packages
                  Atteint http://fr.archive.ubuntu.com gutsy/universe Sources
                  Atteint http://fr.archive.ubuntu.com gutsy/main Sources
                  Atteint http://fr.archive.ubuntu.com gutsy/multiverse Sources
                  Atteint http://fr.archive.ubuntu.com gutsy-security/universe Sources
                  Atteint http://fr.archive.ubuntu.com gutsy-security/main Sources
                  Atteint http://fr.archive.ubuntu.com gutsy-security/multiverse Sources
                  Atteint http://fr.archive.ubuntu.com gutsy-updates/universe Packages
                  Atteint http://fr.archive.ubuntu.com gutsy-updates/main Packages
                  Atteint http://fr.archive.ubuntu.com gutsy-updates/multiverse Packages
                  Atteint http://fr.archive.ubuntu.com gutsy-updates/universe Sources
                  Atteint http://fr.archive.ubuntu.com gutsy-updates/main Sources
                  Ign http://apt.tt-solutions.com etch/main Packages
                  Atteint http://fr.archive.ubuntu.com gutsy-updates/multiverse Sources
                  Err http://apt.tt-solutions.com etch/main Packages
                  404 Not Found
                  5o téléchargés en 0s (6o/s)
                  Lecture des listes de paquets... Fait


                  J'avoue que tout ça me dépasse en tant que débutant.

                  Est-ce que c'est dû au fait qu'il y ait à la fois l'adresse du cd et le paquetage sur internet?

                  demadez et l'on vous répondra, cherchez et vous trouverez, frappez et l'on vous ouvrira.
              3. Modérateur
                Salut,

                vu cette erreur Err http://apt.tt-solutions.com etch/main Packages
                probablement tu as cette ligne deb http://apt.tt-solutions.com etch/main dans /etc/apt/sources.list

                Normalement tu dois mettre
                 deb http://apt.tt-solutions.com/ubuntu/ feisty main
                affiche le résultat de la commande
                cat /etc/apt/sources.list
                1. Ok, donc j'ai réediter mon fichier /etc/apt/sources.list

                  Code : sudo gedit /etc/apt/sources.list

                  Ensuite j'ai remplacé deb http://apt.tt-solutions.com/ubuntu/ etch main par deb http://apt.tt-solutions.com/ubuntu/ feisty main comme tu me l'as dis.

                  Ensuite j'ai enregistré et j'ai refais le code sudo aptitude update et ça m'affiche des dizaines de lignes comme d'habitude mais vers la fin il y a cette erreur :

                  ...
                  ...
                  Atteint http://fr.archive.ubuntu.com gutsy-updates/main Sources
                  Atteint http://fr.archive.ubuntu.com gutsy-updates/multiverse Sources
                  6170o téléchargés en 1s (3140o/s)
                  Lecture des listes de paquets... Fait
                  W: GPG error: http://apt.tt-solutions.com feisty Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 06EA41DE4F6C1E86
                  W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.


                  D'où je tape apt-get update comme il le demande et ça m'affiche ceci :

                  E: Impossible d'ouvrir le fichier verrou /var/lib/apt/lists/lock - open (13 Permission non accordée)
                  E: Impossible de verrouiller le répertoire de liste


                  demadez et l'on vous répondra, cherchez et vous trouverez, frappez et l'on vous ouvrira.
              4. Modérateur
                tape ça
                gpg --keyserver hkp://subkeys.pgp.net --recv-keys 06EA41DE4F6C1E86
                gpg --armor --export 06EA41DE4F6C1E86 | sudo apt-key add -
                sudo apt-get update
                sudo apt-get upgrade
                sudo apt-get install manpages-dev
                1. lors du dernier code d'installation sudo apt-get install manpages-dev
                  j'ai toujours cette erreur de dépendance

                  ....
                  .....
                  Le paquet nuauth n'est pas encore configuré.
                  dpkg : erreur de traitement de nuauth-log-mysql (--configure) :
                  problèmes de dépendances - laissé non configuré
                  Paramétrage de amavisd-new (1:2.4.2-6.2ubuntu1) ...
                  Creating/updating amavis user account...
                  Starting amavisd: head: Ne peut ouvrir `/etc/mailname' en lecture: Aucun fichier ou répertoire de ce type
                  The value of variable $myhostname is "****(identifiantDeMonPC)", but should have been
                  a fully qualified domain name; perhaps uname(3) did not provide such.
                  You must explicitly assign a FQDN of this host to variable $myhostname
                  in /etc/amavis/conf.d/05-node_id, or fix what uname(3) provides as a host's
                  network name!
                  (failed).
                  invoke-rc.d: initscript amavis, action "start" failed.
                  dpkg : erreur de traitement de amavisd-new (--configure) :
                  le sous-processus post-installation script a retourné une erreur de sortie d'état 1
                  Des erreurs ont été rencontrées pendant l'exécution :
                  newpki-server
                  nuauth
                  mnogosearch-common
                  mtop
                  nanourl
                  nuauth-log-mysql
                  amavisd-new
                  E: Sub-process /usr/bin/dpkg returned an error code (1)

                  demadez et l'on vous répondra, cherchez et vous trouverez, frappez et l'on vous ouvrira.
              5. Modérateur
                et si tu fait
                sudo dpkg-reconfigure nuauth
                ça donne quoi?
                1. code : sudo dpkg-reconfigure nuauth

                  résultat : /usr/sbin/dpkg-reconfigure: nuauth est cassé ou partiellement installé

                  demadez et l'on vous répondra, cherchez et vous trouverez, frappez et l'on vous ouvrira.
              6. --

                demadez et l'on vous répondra, cherchez et vous trouverez, frappez et l'on vous ouvrira.