Pas d'image sous VLC

Résolu/Fermé
Cralon Messages postés 557 Date d'inscription samedi 20 octobre 2007 Statut Membre Dernière intervention 11 novembre 2010 - 4 nov. 2007 à 17:25
 Antaray - 24 janv. 2021 à 13:03
Bonjour,

J'utilisais VLC sur ma Fedora, il a toujours très bien marché et j'en était satisfait. J'ai réinstallé entièrement mon PC et depuis, il ne marche plus bien du tout.

Il lit très bien les musiques et les DVD vidéo, mais pour toutes les autres vidéos il n'y a que des problèmes. Pour les divx, wmv, etc il n'y a que le son, pas d'image. Les .fla qu'il lisait très bien ne se lisent plus du tout : ni son ni image.

Je ne comprend pas pourquoi... J'ai essayé avec plusieurs fichiers vidéos, qui fonctionnent tous sur Totem-xine mais pas sous VLC.

VLC a été installé via yum.

Si quelqu'un avait une idée sur la question... J'ai trouvé après de nombreuses recherches, une seule personne qui semblait avoir le même problème et qui n'avait apparemment pas trouvé de solution.

Merci d'avance.

Cralon

8 réponses

Flyman671 Messages postés 4 Date d'inscription samedi 29 octobre 2011 Statut Membre Dernière intervention 5 mai 2012 65
Modifié par Flyman671 le 5/05/2012 à 00:53
Hi, j'arrive après la bataille, mais j'ai trouvé une solution.
En réalité, j'ignore l'origine exacte du bug mais il est survenu après un changement de carte graphique.

Version de VLC 2.01

Avant: Carte graphique Radeon HD 5870 et j'avais son et image lors de la lecture des fichiers avi, mp4 etc

Après installation d'une Radeon HD 7950 Sapphire drivers Catalyst
12.3 et bang, j'avais du son mais plus d'image.
Je suis allé (un peu au hasard) :

Ouvrir VLC puis:

1. menu OUTILS puis PREFERENCES du menu contextuel
2. sélection de la boîte de dialogue "Paramètres Video" par clic sur l'icône "VIDEO" à gauche.
3. A droite de la mention SORTIE est indiqué "Prédéfinie" par défaut.
Normalement, VLC cherche automatiquement le meilleur module de sortie video, mais chez moi, suite aux changements ci-dessus, le programme ne trouvait rien.... En cliquant sur la ligne contenant "Prédéfinie" on obtient le choix entre plusieurs modules (pour certains, c'est du chinois..)
J'ai sélectionné ce qui me paraissait le plus logique: sortie vidéo "DirectX (Directdraw)" puis cliqué sur le bouton ENREGISTRER en bas à droite de la boîte de dialogue. (si cela ne devait pas fonctionner, on peut essayer une ou plusieurs autres options..)
En tout cas, avec cette modif, mon VLC EST REPARTI DU BON PIED!!! Image et son !!

Conclusion: Je ne pense pas que la carte graphique soit en cause, mais peut-être quand même une incompatibilité entre VLC et le driver Catalyst
12.3 qui empêche VLC de trouver automatiquement la sortie vidéo appropriée... comme il le faisait auparavant sans problème.

Fallait juste tomber sur la bonne manip, mais je répète, j'y suis
vraiment allé non pas au hasard, mais avec quand même un peu de jugeotte...

J'espère que cela peut aider

flyman
39
merci beaucoup flyman,c'est fait et c'est bon
0
merci, suite à des mises à jour (je suppose) ça ne marchait plus, après réinstallation de VLC toujours pas d'images. j'ai suivi vos conseils et ça marche.
0
Mercii Fly Man ça marche Vraiment super bien, merci beaucoup ^__^
0
impec ! merci bcp !!!
0
Merci beaucoup pour le tuyau et pour la clarté de l'explication!!
0