Formule rechercheV imbriqué stxt

Résolu/Fermé
Jerome - 25 févr. 2023 à 10:40
 Jerome - 25 févr. 2023 à 12:00

Bonjour la communauté,

Je voulais réaliser une formule en évitant de multiplier les colonnes. Du coup j'ai fait

=RECHERCHEV(STXT(B2;8;2);L:M;2;0) ce qui me donne #N/A comme résultat.

En gros le STXT (valeur cherchée) donne comme résultat le mois de l'année soit 02 précisément pour cette ligne. La colonne L apporte 01 02 03 04 05 06 ETC. et la colonne M Janvier Février Mars Avril Mai Etc.

Donc dans cette exemple là, STXT donnant 02, j'aurais voulu Février comme résultat. Sauriez vous comment faire et ce qui bloque dans ma formule ?

Merciiiiiiiiiiiiiiiiiiiiiii


Windows / Chrome 110.0.0.0

A voir également:

2 réponses

PapyLuc51 Messages postés 4238 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 22 février 2024 1 379
25 févr. 2023 à 11:19

Bonjour,

Est-ce que dans la colonne "L" se sont des nombres ?

Si oui il faut transformer l'extraction avec STXT en nombre avec CNUM

=RECHERCHEV(CNUM(STXT(B2;8;2));L:M;2;0)

Autre méthode pour avoir les mois sans utiliser de tableau de recherche

=CHOISIR(CNUM(STXT(B2;8;2));"janvier";"février";"mars";"avril";"mai";"juin";"juillet";"août";"septembre";"octobre";"novembre";"décembre")

Cordialement

1

Bonjour PapyLuc51,

Un treeeeeeees grand merci. La première méthode est exactement ce que je cherchais ????

Encore merci pour votre aide 

0
brucine Messages postés 13596 Date d'inscription lundi 22 février 2021 Statut Membre Dernière intervention 27 février 2024 1 646
25 févr. 2023 à 11:24

Bonjour,

Ta formule n'est pas cohérente, notamment parce qu'elle part du principe que la ligne correspondant à la recherche contient forcément colonne L le mois rendu par STXT alors qu'elle sera fixe et pourra valoir un autre mois.

En supposant que A1 vaille xxxxxx02, pourquoi ne pas se contenter dans la cellule résultat, disons C1, de:

=(TEXTE(STXT(A1;8;2)*29;"mmmm"))

Le résultat de mmmm est le mois entier (février)

1

Bonjour brucine,

Merci beaucoup pour votre aide. Je vais tester votre méthode et voir si elle répond à mon besoin. Quoiqu'il en soit un très très grand merci pour votre aide

Amicalement 

0