#valeur

Résolu/Fermé
titoune21312 Messages postés 35 Date d'inscription vendredi 4 novembre 2022 Statut Membre Dernière intervention 1 décembre 2023 - 5 janv. 2023 à 15:17
titoune21312 Messages postés 35 Date d'inscription vendredi 4 novembre 2022 Statut Membre Dernière intervention 1 décembre 2023 - 6 janv. 2023 à 09:39

Bonjour, 

je reviens sur ce forum pour encore surement un probleme de parenthése et je m'arrache les cheveux depuis 1h  

sur ma formule qui me donne #valeur 

https://cjoint.com/c/MAfoqHvLsfz

Encore merci d'avance 

3 réponses

T3chN0g3n Messages postés 4864 Date d'inscription samedi 16 février 2019 Statut Membre Dernière intervention 1 mars 2024 1 076
5 janv. 2023 à 15:46

Salut,

Quand tu insert un parenthèse "fermante" ça te met celle qui correspond en gras pendant un bref instant, ça aide pas mal !

=SI(B6<=60;INDEX(H!C6:C100;EQUIV(C5;H!B6:B100;0));SI(BASE!B6<=100;INDEX(H!D6:D100;EQUIV(BASE!C5;H!B6:B100;0));B6*(INDEX(H!A6:E100;EQUIV(BASE!C5;H!B6:B100;0);EQUIV(BASE!B6;H!A3:E3)/1000))))

Cdlt.

0
titoune21312 Messages postés 35 Date d'inscription vendredi 4 novembre 2022 Statut Membre Dernière intervention 1 décembre 2023 2
5 janv. 2023 à 16:45

Salut

merci pour ton aide, 

cependant je ne comprend pas pourquoi je met du coup les nouvelles parenthèses , je ne trouve pas le résultat espéré en gros dans ma formule j'ai fais comme sur les précédentes là

je voudrais que lorsque le poids est moins de 60 il m'affiche 45.27 

quand                            le poids est entre 61 et 100 il m'affiche 60.34

et que ca dépasse les 100 , il me fasse le calcul comme sur les précédentes formules en gros exemple 150 *le prix indiqué dans la base H soit 482.79 /1000 mais là il me met 9051 € 

est encore un probléme de parenthése ? Car celà fonctionnait sur les autres formules ? 

https://cjoint.com/c/MAfpTaf4qcz

Encore merci 

0
ALS35 Messages postés 1033 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 9 janvier 2024 139
Modifié le 5 janv. 2023 à 17:14

Bonjour,

Sur ton premier envoi, il y avait des parenthèses en trop avant le B6* et manquantes autour du /1000 :

A voir

=SI(B6<=60;INDEX(H!C6:C100;EQUIV(C5;H!B6:B100;0));SI(BASE!B6<=100;INDEX(H!D6:D100;EQUIV(BASE!C5;H!B6:B100;0));B6*(INDEX(H!A6:E100;EQUIV(BASE!C5;H!B6:B100;0);EQUIV(BASE!B6;H!A3:E3;1))/1000)))

Cordialement

1
T3chN0g3n Messages postés 4864 Date d'inscription samedi 16 février 2019 Statut Membre Dernière intervention 1 mars 2024 1 076
Modifié le 5 janv. 2023 à 17:35

Ecrire des formules c'est bien, les comprendre c'est mieux...

Effectivement un autre problème de parenthèses !

=SI(B6<=60;INDEX(H!C6:C100;EQUIV(C5;H!B6:B100;0));SI(BASE!B6<=100;INDEX(H!D6:D100;EQUIV(BASE!C5;H!B6:B100;0));B6*(INDEX(H!A6:E100;EQUIV(BASE!C5;H!B6:B100;0);EQUIV(BASE!B6;H!A3:E3)))/1000))


Pour expliquer plus ou moins ce qu'il se passait, là tu divisait par 1000 le résultat de la fonction EQUIV sensé renvoyer le numéro de colonne utilisé par la fonction INDEX, donc forcément ça marchait pas ...

Pour le coup je sais pas trop pourquoi mais comme en numéro de colonne INDEX avait 0.005 (n° de colonne 5 /1000) est que c'est forcément invalide (pour un n° de colonne), il semble prendre par défaut le n° de colonne de la cellule dans laquelle il ce trouve. Donc ici la colonne D, ont retrouvait donc bien le 60.34 x 150 = 9051.

1
ALS35 Messages postés 1033 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 9 janvier 2024 139 > T3chN0g3n Messages postés 4864 Date d'inscription samedi 16 février 2019 Statut Membre Dernière intervention 1 mars 2024
Modifié le 5 janv. 2023 à 17:59

Bonjour,

@T3chN0g3n StatutMembre

C'est équivalent à kesque jaidi, et en plus le dernier EQUIV est une recherche par valeur inférieure, je préfère donc ne pas omettre le 1 en troisième paramètre, même si c'est le fonctionnement par défaut et ça reste homogène avec les formules au dessus.

Cordialement

0
ALS35 Messages postés 1033 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 9 janvier 2024 139 > T3chN0g3n Messages postés 4864 Date d'inscription samedi 16 février 2019 Statut Membre Dernière intervention 1 mars 2024
5 janv. 2023 à 18:38

Re,

@T3chN0g3n StatutMembre

Oh pas de souci, ça m'arrive souvent aussi. Mon propos n'était pas là mais plutôt de bien préciser le paramètre EQUIV.

D'ailleurs je pense qu'il est peut-être inutile, je vais voir.

Cordialement

1
ALS35 Messages postés 1033 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 9 janvier 2024 139 > ALS35 Messages postés 1033 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 9 janvier 2024
5 janv. 2023 à 21:19

Bonsoir,

Je confirme, vu le tableau de données feuille H,  la formule en Base!D19 peut être simplifiée en :

=SI(B6<=60;INDEX(H!C6:C100;EQUIV(C5;H!B6:B100;0));SI(BASE!B6<=100;INDEX(H!D6:D100;EQUIV(BASE!C5;H!B6:B100;0));B6*INDEX(H!E6:E100;EQUIV(BASE!C5;H!B6:B100;0))/1000))

Ci-joint fichier modifié, j'en ai profité pour corriger toutes les formules colonnes E à I, qui sont juste là pour aider à la compréhension (peut-être ??)

On pourrait probablement simplifier les formules en D13:D18 mais je ne l'ai pas fait.

https://www.cjoint.com/c/MAfurLdlM6y

Cordialement

1
titoune21312 Messages postés 35 Date d'inscription vendredi 4 novembre 2022 Statut Membre Dernière intervention 1 décembre 2023 2
6 janv. 2023 à 09:39

Je comprend mieux ce fameux résultat que je n'arrivais pas à voir le pourquoi du comment ! 

Merci à tous pour vos explications et vos aides ! :)

0