Problème à résoudre dans un tableau excel.

Résolu/Fermé
JPL_2021 Messages postés 16 Date d'inscription lundi 8 mars 2021 Statut Membre Dernière intervention 17 octobre 2023 - 12 déc. 2022 à 19:46
JPL_2021 Messages postés 16 Date d'inscription lundi 8 mars 2021 Statut Membre Dernière intervention 17 octobre 2023 - 16 déc. 2022 à 09:20

Bonjour,

j'ai un petit problème à résoudre:

j'ai une liste de noms en colonne A. Dans les colonnes qui suivent, un chiffre est associé a chacun des noms.
Dans la colonne I, je voudrais totaliser tous les chiffres associés a ces noms.

exemple : 22 de la colonne I correspond au total des chiffres 9+4+9 des colonnes C,E,G pour le nom alpha.

Existe t'il une formule pour réaliser cette opération?

D'avance, merci.

A voir également:

2 réponses

ALS35 Messages postés 1033 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 9 janvier 2024 139
12 déc. 2022 à 21:14

Bonjour,

Au plus simple, en I1 et à recopier vers le bas :

=SOMME.SI($B$1:$B$5;H1;$C$1:$C$5)+SOMME.SI($D$1:$D$5;H1;$E$1:$E$5)+SOMME.SI($F$1:$F$5;H1;G$1:G$5)

Cordialement

1
JPL_2021 Messages postés 16 Date d'inscription lundi 8 mars 2021 Statut Membre Dernière intervention 17 octobre 2023
13 déc. 2022 à 10:05

Merci, ça marche bien, mais si mon tableau comporte x paires de colonnes, je vais devoir répéter  x fois

la formule  +SOMME.SI($D$1:$D$5;H1;$E$1:$E$5).+ ........

Y aurait il une formule qui tienne compte du nombre de paires de colonnes a additionner ?

Je complique mais c'est ce que je dois résoudre.

merci d'avance.

0
ALS35 Messages postés 1033 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 9 janvier 2024 139 > JPL_2021 Messages postés 16 Date d'inscription lundi 8 mars 2021 Statut Membre Dernière intervention 17 octobre 2023
13 déc. 2022 à 10:30

Bonjour,

Alors essaie en I1 :

=SOMME(SIERREUR(($B$1:$F$5=$H1)*$C$1:$G$5;""))

Formule matricielle à valider par Ctrl+Maj+Entrée, elle se met alors automatiquement entre accolades {}

Et à recopier vers le bas

Cordialement

0
JPL_2021 Messages postés 16 Date d'inscription lundi 8 mars 2021 Statut Membre Dernière intervention 17 octobre 2023 > ALS35 Messages postés 1033 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 9 janvier 2024
14 déc. 2022 à 19:23

Super ça a l'air de marcher, j'ai realisé le tableau  ci dessus pour faire le test mais il y a un petit bémol, la formule ne veut pas additionner la cellule E6 quelque soit la valeur rentrée. La formule utilisée en K6 est la suivante:{=SOMME(SIERREUR(($B$1:$H$7=$J6)*$C$1:$I$7;""))}.

Y a t'il une explication?

Merci

0
ALS35 Messages postés 1033 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 9 janvier 2024 139 > JPL_2021 Messages postés 16 Date d'inscription lundi 8 mars 2021 Statut Membre Dernière intervention 17 octobre 2023
15 déc. 2022 à 09:08

Bonjour,

Il y a surement une explication. Cette cellule est peut-être sous forme de texte.

Mais à la place d'une image qui nous oblige à tout recopier, fournis plutôt ton fichier exemple en passant par cjoint.com (par exemple) et en donnant ici le lien créé.

Cordialement

0
JPL_2021 Messages postés 16 Date d'inscription lundi 8 mars 2021 Statut Membre Dernière intervention 17 octobre 2023 > ALS35 Messages postés 1033 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 9 janvier 2024
15 déc. 2022 à 16:46

merci voici le fichier:

https://cjoint.com/c/LLppSnprXhI

0
Mike-31 Messages postés 18310 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 29 mars 2024 5 073
12 déc. 2022 à 21:30

Bonsoir,

tu as également

=SOMMEPROD(($B$1:$B$5=H1)*($C$1:$C$5)+($D$1:$D$5=H1)*($E$1:$E$5)+($F$1:$F$5=H1)*($G$1:$G$5))


0