Calculer le nombre de double

Résolu/Fermé
mic6259 Messages postés 342 Date d'inscription mercredi 4 mars 2015 Statut Membre Dernière intervention 11 décembre 2023 - 25 nov. 2022 à 15:27
Mike-31 Messages postés 18306 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 14 février 2024 - 25 nov. 2022 à 18:22

Bonjour a tous

Dans le fichier joint, j'aimerais que dans la cellule D2 affiche le nombre de double, dans les colonnes A et B il y a actuellement 3 doubles.

J'ai essayé plusieurs codes mais sans succès.

Merci pour votre aide


https://www.cjoint.com/c/LKzozjpQvYN

A voir également:

4 réponses

yclik Messages postés 3527 Date d'inscription vendredi 25 juillet 2014 Statut Membre Dernière intervention 24 février 2024 1 465
25 nov. 2022 à 15:48

Bonjour

une piste

=NB.SI(A2:A$5;A2)
=NB.SI(B2:B$5;B2)
=NB.SI(D2:E7;2)
0

Bonjour yclic

Est-ce possible de calculer en une seule etape

Merci beaucoup 

Cordialement 

0
ALS35 Messages postés 1033 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 9 janvier 2024 139
25 nov. 2022 à 16:52

Bonjour à tous,

Une proposition assez longue qui tient compte également des triplons et plus:

=SOMMEPROD(1/NB.SI(A2:A5;A2:A5)*(1/NB.SI(A2:A5;A2:A5)<1))+SOMMEPROD(1/NB.SI(B2:B5;B2:B5)*(1/NB.SI(B2:B5;B2:B5)<1))

Il y a probablement mieux.

Cordialement

0
mic6259 > ALS35 Messages postés 1033 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 9 janvier 2024
25 nov. 2022 à 17:33

Merci beaucoup ZLS35

En effet, un peut longue mais efficace 

Cordialement 

0
Mike-31 Messages postés 18306 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 14 février 2024 5 062
25 nov. 2022 à 17:33

Bonjour,

essaye simplement comme cela

=SOMME(SI(FREQUENCE(A2:B5;A2:B5)>1;1))


0
ALS35 Messages postés 1033 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 9 janvier 2024 139
25 nov. 2022 à 18:10

Bonjour à tous de nouveau,

Argh, je savais bien qu'il y avait mieux, je ne pense jamais à FREQUENCE.

Telle que, elle prend également les doublons entre les deux colonnes, à dédoubler et sommer si nécessaire.

Cordialement

0
Mike-31 Messages postés 18306 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 14 février 2024 5 062
25 nov. 2022 à 18:22

Re,

Si ton problème est résolu n'oublie pas de passer le statut de la discussion en résolu


0