Formule Excel qui reconnait les multiples de 100

Résolu/Fermé
nancy_soleil08 Messages postés 58 Date d'inscription vendredi 15 avril 2016 Statut Membre Dernière intervention 5 juin 2023 - 7 juil. 2022 à 22:32
nancy_soleil08 Messages postés 58 Date d'inscription vendredi 15 avril 2016 Statut Membre Dernière intervention 5 juin 2023 - 8 juil. 2022 à 17:44

Bonjour, je cherche comment formuler dans Excel la question suivante:

si le résultat d'une cellule donnée est un multible de 100 exacte, je veux la réponse "r", si le résultat de la cellule n'est pas un multiple de 100, je veux la réponse "t"

Exemple si g2 = 200, réponse de h2= "r" car se divise par 100, sinon réponse "t'. Donc si g2 = 102, réponse "t"

h2= if(g2/100= ???...,"r","t")

Je ne sais pas comment le formuler plus simplement, mais merci de votre aide...

A voir également:

3 réponses

via55 Messages postés 14426 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 6 juin 2024 2 711
7 juil. 2022 à 22:52

Bonjour nancy_soleil

la fonction MODULO est là pour ça

=SI(MOD(G;100);"r";"t")

Cdlmnt

Via


1
Raymond PENTIER Messages postés 58499 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 17 juin 2024 17 132
8 juil. 2022 à 02:42

Le "2" de G2 est resté en suspens ...

Mais c'est la bonne formule !

0
PapyLuc51 Messages postés 4342 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 15 juin 2024 1 421
8 juil. 2022 à 04:40

Salutations à tous

C'est plutôt le contraire pour le VRAI et FAUX ; la fonction MOD renvoie le reste d'une division

S'il y a un reste à la division par 100 on met "t" ; si le reste est 0 c'est "r"

=SI(MOD(G2;100);"t";"r")

Cordialement

0
PapyLuc51 Messages postés 4342 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 15 juin 2024 1 421
8 juil. 2022 à 06:03

ou alors

=SI(MOD(G2;100)=0;"r";"t")

Cordialement

0
nancy_soleil08 Messages postés 58 Date d'inscription vendredi 15 avril 2016 Statut Membre Dernière intervention 5 juin 2023
8 juil. 2022 à 17:44

Super cela fonctionne ! Merci !!!

0