Fichier BUDGETS : Feuille BD articles budgets. TabBDAB

Résolu/Fermé
BUDGETS Messages postés 1346 Date d'inscription samedi 19 juillet 2014 Statut Membre Dernière intervention 13 juillet 2024 - 13 févr. 2022 à 22:45
BUDGETS Messages postés 1346 Date d'inscription samedi 19 juillet 2014 Statut Membre Dernière intervention 13 juillet 2024 - 14 févr. 2022 à 16:06
Bonsoir à toutes, à tous.
Dans ce fichier, feuille BD articles budgets, tableau BDAB : après un clic sur Valider création articles budgets, l'enregistrement supprime le nom des colonnes qu'il remplace par le contenu des cb, tb, etc.. Merci de m'aider à régler ce problème.
Bonnes fin de soirée, nuit et continuation.
https://www.cjoint.com/c/LBnvSIvjrPQ
A voir également:

2 réponses

f894009 Messages postés 17196 Date d'inscription dimanche 25 novembre 2007 Statut Membre Dernière intervention 13 juillet 2024 1 708
14 févr. 2022 à 11:44
Bonjour,

Fichier modifie: https://www.cjoint.com/c/LBokQgp5wVf
BUDGETS Messages postés 1346 Date d'inscription samedi 19 juillet 2014 Statut Membre Dernière intervention 13 juillet 2024
14 févr. 2022 à 12:00
Bonjour f894409

Dans le fichier, vous avez ajouté cette instruction dans l'UserForm UF01_CAB, procédure cmdVCAB_Click ?
If Range("TabBDAB[CNAB]").Item(Ici) <> "" Then
Avez-vous procéder à d'autres modifications et si oui, lesquelles et où ?
Merci pour votre réponse à venir et pour celle-ci.
0
BUDGETS Messages postés 1346 Date d'inscription samedi 19 juillet 2014 Statut Membre Dernière intervention 13 juillet 2024
14 févr. 2022 à 12:26
J'ai modifié mon code. J'ai créé un nouvel article mais l'enregistrement ne se fait pas à la ligne où il devrait être. J'ai fait un deuxième enregistrement qui a effacé le premier et toujours pas à la bonne ligne.
https://www.cjoint.com/c/LBolzYKq85Q
0
BUDGETS Messages postés 1346 Date d'inscription samedi 19 juillet 2014 Statut Membre Dernière intervention 13 juillet 2024
14 févr. 2022 à 14:06
Dans votre feuille code, lgart = 0 et cela fonctionne. Dans le mien, j'ai fait un copier coller du vôtre et cela ne marche pas (voir message 3). J'ai modifié lgart en mettant 1 au lieu de 0 et là cela fonctionne. Avez-vous une idée du pourquoi de la chose ?
0