Fonction trier

[Résolu]
Signaler
Messages postés
7
Date d'inscription
dimanche 10 octobre 2021
Statut
Membre
Dernière intervention
14 octobre 2021
-
Messages postés
10505
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 octobre 2021
-
Bonjour,
Don mon fichier Excel j'utilise la formule:
=SIERREUR(INDEX(produits;PETITE.VALEUR(SI(FREQUENCE(SI(produits<>"";EQUIV(produits;produits;0)); LIGNE(produits)-LIGNE($B$6)+1);LIGNE(produits)-LIGNE($B$6)+1);LIGNES(I$210:I210)));"")


Le problème je n'arrive pas a utilisé la fonction trier dans mon tableau.

Merci d'avance pour votre aide.

11 réponses

Messages postés
10505
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 octobre 2021
1 220
Bonjour,
Eh bien normalement on utilise les outils Trier et Filtrer de l'onglet Données.
D'où vient cette fonction ...! je pense qu'il s'agit d'une fonction matricielle que vous devez valider avec la touche Enter +Ctrl+Shift enfoncées.
Messages postés
54884
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
16 783
Bonjour.

Ta formule effectue déjà une sorte de tri ; si tu veux appliquer l'outil trier par-dessus, normal que ça ne fonctionne pas ! Il faut choisir entre lancer un tri ou écrire ta formule ...
Messages postés
7
Date d'inscription
dimanche 10 octobre 2021
Statut
Membre
Dernière intervention
14 octobre 2021

Bonjour,

Je partage mon fichier:
https://www.partage-temporaire.fr/2021/10/12/exemple-2/

Sur l'onglet "organisation" je n'arrive pas a trier les tableaux manuellement, j'essai de modifier la formule mais sans sucée.
Messages postés
54884
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
16 783
Désolé : ma messagerie annonce un virus et refuse d'ouvrir ton lien ...
Messages postés
7
Date d'inscription
dimanche 10 octobre 2021
Statut
Membre
Dernière intervention
14 octobre 2021

Je vais essayer de le partager directementle fichier depuis le cloud de Excel.
Messages postés
10505
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 octobre 2021
1 220
Bonjour,
Le plus simple c'est de le faire avec https://www.cjoint.com/ et poster le lien!
Messages postés
7
Date d'inscription
dimanche 10 octobre 2021
Statut
Membre
Dernière intervention
14 octobre 2021

Deuxième tentative ci-dessous.

https://www.cjoint.com/c/KJnrqd6KG4G
Messages postés
10505
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 octobre 2021
1 220
Bonjour,
Dans un premier temps, pourquoi y a-t-il 2 tableaux Excel [Tableau4] et [Tableau6a] ?
A quoi doit servir votre formule [=SIERREUR(INDEX(p.....]?
Et sur quoi doit agir le tri?

Salutations.
Le Pingou
Messages postés
7
Date d'inscription
dimanche 10 octobre 2021
Statut
Membre
Dernière intervention
14 octobre 2021

Je doit dire que je m'exprime vraiment mal et que j'ai mal indiquer ma demande....

Le principe "je rénove des maison"

1-Base de donnée
1.1-J'introduit mes produits pour les récupérer dans l'onglet Barnault.

2-Barnault
2.1- colonne A ''liste des salles a rénover" (exemple salle a manger, salle de bain, chambre)
2.2- colonne B ''description'' devant chaque salle a rénover je récupère les produits en créant une liste depuis la base de donnée.
2.3- colonne C ''quantité'' j'insère manuellement les quantité de chaque produit

3-Récapitulatif
3.1- colonne A "indique avec la fonction recherche de quelle salle vient le produit
3.2- colonne B "calcule la quantité du même produit dans toute les salles.
3.3- ""fonction trier colonne A"" afficher seulement les salles que j'ai besoin.
Messages postés
10505
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 octobre 2021
1 220
Bonsoir,
Merci du retour.
Je reprendrai la suite demain après-midi.
Messages postés
7
Date d'inscription
dimanche 10 octobre 2021
Statut
Membre
Dernière intervention
14 octobre 2021

Merci de votre aide.
Bonne soirée.
Messages postés
54884
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
16 783
Jonathan, il faut vraiment te concentrer !

Le fichier que tu as envoyé dans le post #7 ne correspond pas à tes explications détaillées du post #9 :
2.1- Il n'y a pas de liste de salles
2.2- La colonne B ne contient pas de description, mais les quantités
3.1- La formule ne peut renvoyer que la description (colonne B de BD), et pas une salle !

Impossible dans ces conditions de travailler sur le fichier ...
Messages postés
7
Date d'inscription
dimanche 10 octobre 2021
Statut
Membre
Dernière intervention
14 octobre 2021

Tu as tout à fait raison Raymond.

J'ai expliqué à Le Pingou que je m'exprime vraiment mal et que j'ai mal indiquer ma demande....

Mon travail finit, je monte le fichier proprement sans faute.

Bonne journée.
Messages postés
10505
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 octobre 2021
1 220
Bonjour,
Eh oui j'attends le fichier amélioré !