Google Sheets : Dernière cellule non vide - Première cellule non vide

Fermé
mafia97231 Messages postés 25 Date d'inscription mercredi 27 novembre 2013 Statut Membre Dernière intervention 8 septembre 2022 - Modifié le 17 août 2021 à 03:36
mafia97231 Messages postés 25 Date d'inscription mercredi 27 novembre 2013 Statut Membre Dernière intervention 8 septembre 2022 - 17 août 2021 à 16:59
Bonjour,

J'ai un tableau de planning (simplifié pour l'occasion).
J'y ai mis une mise en forme conditionnelle : la cellule se colore (le texte aussi) quand elle est non vide.
Je veux laisser le choix à l'éditeur de mettre n'importe quoi dans les cellules (texte ou nombre).

Pouvez-vous m'aider à calculer l'amplitude horaire (heures effectuées sur la journée + pause)des salariés ?
Pour le calcul des heures effectuées, je n'ai pas de problème.

Ensuite, si possible de m'aider également dans le calcul des temps de pause.

Je suis sur des pistes : en cellule BE2, la fonction EQUIV me permet d'avoir le numéro de colonne de la première cellule non vide). En cellule BE6, j'arrive à avoir le numéro de colonne de la dernière cellule non vide texte (ca ne marche pas si c'est un chiffre).

Des pistes ?

Mon tableau : https://docs.google.com/spreadsheets/d/1cc9NIdSKQ1jcICDIXQ6Cb0Ftrp8hbnCG_EjFxkvXQwI/edit?usp=sharing

Je vous remercie beaucoup :)

Configuration: Windows / Chrome 92.0.4515.131
A voir également:

6 réponses

PapyLuc51 Messages postés 3807 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 5 décembre 2022 1 201
Modifié le 17 août 2021 à 09:41
Bonjour,

J'ai trouvé une formule matricielle pour calculer l'amplitude.


=SIERREUR(ArrayFormula(max(SI(B2:BC2<>"";COLONNE(B2:BC2)))-EQUIV(VRAI;INDEX(B2:BC2>0;0);0))*0,25/24;"")


Pour le temps de pose
=SI(SOMME(BE2;-BD2)=0;"";SOMME(BE2;-BD2))


Voir ton fichier exemple

Cordialement
1