Formule % gains [Résolu]

Signaler
Messages postés
21
Date d'inscription
mercredi 7 avril 2021
Statut
Membre
Dernière intervention
10 juillet 2021
-
Messages postés
26106
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
-
Bonjour,
Je suis joueur de Poker et je garde un tableau Excel de mes mains/pertes.

Je dépense 0,50 pour un gain potentiel de 0.92
Donc dans mon tableau j’ai dépense, gains, résultat net
Comment calculer le % de gain (je veux dire le % du nombre de fois ou j’ai gagné)

Par exemple j’ai gagné 14 fois contre 10 fois perdu ca me donne 58% de parties gagnées

Je voudrais pouvoir calculer ce pourcentage dans une formule comment faire ?

Pour info, j’ai une dernière colonne qui est soit à 1 (gain) soit à -1 (perte)

Merci d’avance
Virtuellement
ZeBoulet93


Configuration: Windows / Chrome 91.0.4472.124

5 réponses

Messages postés
26106
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
5 992
Bonjour
si -1 et +1 dans colonne D par exemple, de D2 à D1000, à adapter
% de gain sur le nombre de parties jouées:
=NBVAL($D$2:$D$1000;">0")/NBVAL($D$2:$D$1000)
format de cellule en %, nombre de décimales à choisir
crdlmnt
Messages postés
21
Date d'inscription
mercredi 7 avril 2021
Statut
Membre
Dernière intervention
10 juillet 2021

Bonjour,
Merci je viens de tester.
Ca me donne 102 % au lieu de 50% logiquement (environ)
C'est la colonne F sur 60 lignes pour le moment

Ma colonne F comporte que des 1 ou des -1
1 je gagne -1 je perd

Le calcul doit être mauvais je devrais être aux alentours de 50% pas 102%

En fait j'en ai joué 58 gagnés 30 perdus 28

Merci d'avance
Virtuellement
ZeBoulet93
Messages postés
26106
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
5 992
Excusez....Faute de texte dans la formule au début (c'est une de mes spécialités):
pour F2:F100:
=NB.SI($F$2:$F$100;">0")/NBVAL($F$2:$F$100)
crdlmnt

Messages postés
21
Date d'inscription
mercredi 7 avril 2021
Statut
Membre
Dernière intervention
10 juillet 2021

Re,
Ahhhhh c'est bcp mieux
Ca marche !!!


Merci !
@+
ZeBoulet93
Messages postés
26106
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
5 992
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt