Formule plusieurs critères avec lignes pas toutes remplies

Résolu/Fermé
rcarbonne Messages postés 3 Date d'inscription jeudi 21 juillet 2016 Statut Membre Dernière intervention 8 juillet 2021 - Modifié le 6 juil. 2021 à 18:15
rcarbonne Messages postés 3 Date d'inscription jeudi 21 juillet 2016 Statut Membre Dernière intervention 8 juillet 2021 - 8 juil. 2021 à 20:06
Bonjour, je chercher une qui me permettre de ramener une valeur ayant deux critères et dont l'un des critères ne se répète pas sur toutes les lignes.

3 réponses

The_boss_68 Messages postés 851 Date d'inscription dimanche 15 novembre 2015 Statut Membre Dernière intervention 30 janvier 2023 160
6 juil. 2021 à 20:50
Bonjour,

Difficile de travailler sur une image, un fichier EXCEL complété par des explications exhaustives annonymisé mis sur https://www.cjoint.com/ permettrait aux intervenants de répondre plus précisément à ta question.

Slts
0
rcarbonne Messages postés 3 Date d'inscription jeudi 21 juillet 2016 Statut Membre Dernière intervention 8 juillet 2021
Modifié le 6 juil. 2021 à 21:54
Merci pour l'information, je ne savais pas comment faire pour fournir le fichier excel.

https://www.cjoint.com/c/KGgt1Pfyj2G
0
The_boss_68 Messages postés 851 Date d'inscription dimanche 15 novembre 2015 Statut Membre Dernière intervention 30 janvier 2023 160
8 juil. 2021 à 19:05
Bonjour,

En tout les cas merci d'avoir mis le fichier en lien, par contre je ne comprend pas trop ce que tu veux, tes données en colonne G m’embrouille un peu du coup essaye d'être un peu plus clair dans ce que tu veux.

Slts
0
rcarbonne Messages postés 3 Date d'inscription jeudi 21 juillet 2016 Statut Membre Dernière intervention 8 juillet 2021
8 juil. 2021 à 20:06
Bonjour,
L'information dans la colonne G est une formule que j'ai utilisé pour les 4 premières lignes.
J'ai finalement trouvé une solution, je ne pensais pas que les cellules sans titres ex: Cellule B16 Affaire se recopiait dans les cellules subséquentes soient B17 à B19 sans que Affaire soit visible. Donc voici deux formules que j'ai créé et qui font référence à une autre feuille.
=SIERREUR(SI(ET($C17;$B17;'Consommation 21-22_FP'!$C17;'Consommation 21-22_FP'!$B17;'Consommation 21-22_FP'!$D17);'Consommation 21-22_FP'!$D17);"0 ")
ou
=SIERREUR(INDEX('Consommation 21-22_FP'!$B$16:$D$384;EQUIV($C17 & $B17;'Consommation 21-22_FP'!$B$16:$D$384;0););'Consommation 21-22_FP'!$D17)

Merci d'avoir essayé de m'aider.
Renée
0