Extraire numéro et nom de rue [Résolu]

Signaler
Messages postés
2
Date d'inscription
mardi 8 juin 2021
Statut
Membre
Dernière intervention
8 juin 2021
-
Messages postés
2
Date d'inscription
mardi 8 juin 2021
Statut
Membre
Dernière intervention
8 juin 2021
-
Bonjour à tous,
J'avais trouvé/utilisé, il y a quelque temps, deux formules excel qui me permettaient de scinder une cellule contenant une adresse en deux cellules (numéro & rue)
Malgré mes nombreuses recherches, impossible de remettre la main dessus?..
Alors je fais appel à vous, la communauté !

Voila ce que j'ai dans ma colonne A :
32 AVENUE DE TIERCE
432 CHEMIN DE FRETE
ALLEE TEST

Ce que je veut dans la colonne B :
"32"
"432"
"-vide-"

Et dans la colonne C :
"AVENUE DE TIERCE"
"CHEMIN DE FRETE"
"ALLEE TEST"

Merci à tous !

2 réponses

Messages postés
32109
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
10 juin 2021
7 721
Bonjour,

Essayer
=SI(ESTNUM(CNUM(STXT(A1;1;1)));STXT(A1;1;TROUVE(" ";A1));" ")

et
=SI(ESTNUM(CNUM(STXT(A1;1;1)));STXT(A1;TROUVE(" ";A1)+1;200);A1)

le distinguo se faisant sur le 1er caractère, numérique ou pas
Messages postés
2
Date d'inscription
mardi 8 juin 2021
Statut
Membre
Dernière intervention
8 juin 2021

C'est exactement ce que je cherchais !!
Merci beaucoup ;-)