Modifier l'argument vecteur_recherche de fonction recherche selon cellule

Signaler
Messages postés
8
Date d'inscription
jeudi 1 janvier 2015
Statut
Membre
Dernière intervention
4 juin 2021
-
Messages postés
9880
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
21 juin 2021
-
Bonjour,

J'ai une cellule A1 dans laquelle je saisis une année.
De la valeur de cette cellule j'aimerais modifier la feuille de recherche de ma fonction RECHERCHE en A3.
Exemple:
Valeur saisie en A1: 2021, formule en A3
=RECHERCHE("Total des dossiers "&A1&"";'2021'!A1:A100;'2021'!C1:C100)
Et si je tape en A1 2011, j'aimerais que ma formule effectue la recherche dans la feuille 2011 soit:
=RECHERCHE("Total des dossiers "&A1&"";'2011'!A1:A100;'2011'!C1:C100)

J'espère avoir été clair, merci d'avance

1 réponse

Messages postés
9880
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
21 juin 2021
2 141
Bonjour

Pas très bien compris ta formule, mais
Si tu veux la somme de la plage C1:C10
de la feuille dont le nom est Total des dossiers - suivi de l'année qui se trouve en A1
tu as ceci
=SOMME(INDIRECT("'Total des dossiers -" & A1 & "'!C1:C10"))

Cdlmnt