Recherche département excel [Résolu]

Signaler
-
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
-
Bonjour,
J'aimerais classer une colonne avec des départements par région.
Dans une colonne j'ai les numéros des départements et dans les colonnes d'à coté j'aimerai avoir 1 ou 0 si le numéro de département correspond à la colonne de la région.
J'ai essayé cette formule pour la région ile de france mais sans succès...
=SI(OU(NB.SI(H:H;"75");NB.SI(H:H;"91");NB.SI(H:H;"92");NB.SI(H:H;"93");NB.SI(H:H;"94");NB.SI(H:H;"95"));1;0)
Pourriez vous m'aider?
Merci

9 réponses

Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 956
Bonjour
votre formule devrait fonctionner, mais si en colonne H vos N° sont en format nombres il faut enlever les guillemets dans la formule , car Excel les considère comme des textes
crdlmnt

Merci pour la réponse mais même en enlevant les guillemets, Excel me met des 1 partout !
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 956
Alors il serait bien de mettre à disposition votre modèle sans info confidentielle
par exemple ici:
https://mon-partage.fr/
et revenez coller le lien créé sur le site
Désolé si ma question manque de clarté, voici les cellules en question.
https://mon-partage.fr/f/9RkROxGM/
Messages postés
54062
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 juin 2021
16 062
Bonjour.

Vous avez oublié un léger détail : Où se trouve votre tableau avec la liste des départements par région ?
Je compte créer une colonne par région
Messages postés
54062
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 juin 2021
16 062
Eh bien on l'attend avec impatience ...
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers
Il existe aussi :
1) https://mon-partage.fr/
2) https://www.transfernow.net/


Mais en attendant, tu devrais essayer en ligne 2 la formule
=SI(OU(NB.SI(H2;"75");NB.SI(H2;"91");NB.SI(H2;"92");NB.SI(H2;"93");NB.SI(H2;"94");NB.SI(H2;"95"));1;0)

C'est bien, la retraite ! Surtout aux Antilles ... 
Raymond (INSA, AFPA)
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 956
Bonjour
si vous utiliser HH complet dans le NB.SI, vous finirez toujours pas trouver le N° dans la colonne H!
Mais au plus simple, car NB.SI semble superflus dans ce cas:

=SI(OU(H2=75;H2=91;H2=93;H2=94;H2=95);1;0)

à tirer sur la hauteur

ou alors
faire une liste hors champ des n° à affecter par exemple en Z1:Z5
et placer la formule:
=NB.SI($Z$1:$Z$5;H2)
attention au $ aux bons endroits pour tirer la formule

Et en complément un petit modèle exemple pour affecter les régions dans la même colonne à partir d'un tableau de référence (à remplir dans le modèle suivant le nota)
https://mon-partage.fr/f/gwXQB8tU/

crdlmnt

Ça marche ! Merci beaucoup
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 956
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt