Somme de lettre X dans une colonne, mais chaque X doit compter 1 [Résolu]

Signaler
-
 bibi -
Bonjour,

Voilà mon problème, je ne suis vraiment pas connaisseuse des formules En gros c'est faire la somme des X dans chaque colonne, sachant que chaque X doit être comptabilisé pour 1

Je vous remercie de votre aide.

1 réponse

Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 956
Bonjour
la question importante: pouvez vous avoir plusieurs X dans la même cellule dans cette colonne?
A vous lire
en attendant, pour un champ de A2 à A5 à adapter
Si au maximum un X par cellule
=NB.SI(A2:A5;"X")
et s'il faut compter plusieurs X dans les cellules:
=SOMMEPROD((NBCAR(A2:A10))*1)-SOMMEPROD((NBCAR(SUBSTITUE(A2:A10;"X";""))*1))
dans ce second cas, bien limiter le nombre de lignes (pas de A:A ou idem)
à suivre?
crdlmnt

Merci de votre réponse.
Bien cordialement