Compter le nombre de cellules identiques qui se suivent [Résolu]

Signaler
Messages postés
27
Date d'inscription
samedi 14 décembre 2019
Statut
Membre
Dernière intervention
2 mai 2021
-
Messages postés
27
Date d'inscription
samedi 14 décembre 2019
Statut
Membre
Dernière intervention
2 mai 2021
-
Bonjour la communauté,

J'aimerai savoir quelle est la formule qui me permettrait de compter le nombre de cellules identiques qui se suivent pour en faire un indicateur, exemple:

Si dans un planning un salarié ne peux pas travailler plus de 4 jours d'affilé et que je souhaite éviter les erreurs dans mon planning :




La photo de ce vers quoi j'oriente l'indicateur, je me charge de la mise en forme conditionnelle pour le visuel ;)

Merci à vous !

Bubus31

5 réponses

Messages postés
24038
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
6 751
Bonjour,

un repos peut-il être au milieu de 2 travail ?
Toujours 6 cellules ?
eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Messages postés
27
Date d'inscription
samedi 14 décembre 2019
Statut
Membre
Dernière intervention
2 mai 2021

Oui effectivement, ca peut faire ça :

Messages postés
53786
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
15 795 >
Messages postés
27
Date d'inscription
samedi 14 décembre 2019
Statut
Membre
Dernière intervention
2 mai 2021



Bonjour.

En fonction du message de 18:07, la formule-miracle serait
=SI(OU(B2="R";G2="R");"OK";"Interdit")
Messages postés
27
Date d'inscription
samedi 14 décembre 2019
Statut
Membre
Dernière intervention
2 mai 2021
>
Messages postés
53786
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
2 mai 2021

Bonjour Raymond,

Enfait le but pour moi va être de surveiller que je n'ai pas mis plus de 4 fois d'affilé le mot "TRAVAIL" et que la formule puisse me vérifier ça :)

Bubus31
Messages postés
2432
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
1 mai 2021
1 098
Bonsoir
Pas évident sans macro
une piste dans ce classeur
voir tous les cas de figure pouvant se poser
Messages postés
27
Date d'inscription
samedi 14 décembre 2019
Statut
Membre
Dernière intervention
2 mai 2021

La macro serait effectivement plus appropriée, le binaire à l'air assez complexe :p
Messages postés
24038
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
6 751
Bonjour,

en réfléchissant autrement tout se simplifie.
Tu ne peux avoir 5 T consécutifs que si tu as un seul R au début ou à la fin :
=SI(ET(NB.SI(A2:F2;"R")=1;OU(A2="R";F2="R"));5;"ok")

eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Messages postés
24038
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
6 751
Qu'on peut aussi écrire ainsi d'ailleurs :
=SI(OU(NB.SI(A2:E2;"T")=5;NB.SI(B2:F2;"T")=5);"nok";"ok") 
Messages postés
53786
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
15 795
Bonsoir, Bubus31 et Eric.

Il me semblait pourtant que ma proposition de 19:07 répondait exactement à la question posée !
Messages postés
24038
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
6 751
Bonjour raymond,
Pas tout à fait, tu as mis une condition nécessaire mais pas suffisante.
eric
Messages postés
53786
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
15 795 >
Messages postés
24038
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
2 mai 2021

Exact ...
Messages postés
27
Date d'inscription
samedi 14 décembre 2019
Statut
Membre
Dernière intervention
2 mai 2021

Super cela fonctionne ! et le tout sans macro ;)

Merci à tous !