Excel : DATEDIF avec 29 février

Résolu/Fermé
Sopie31 Messages postés 47 Date d'inscription samedi 17 août 2013 Statut Membre Dernière intervention 1 mai 2021 - 1 mai 2021 à 12:30
Mike-31 Messages postés 18113 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 25 novembre 2022 - 1 mai 2021 à 21:25
Bonjour,

J'ai un tableau excel avec des dates de naissance et le calcul automatique de l'âge de la personne. Tout marchait très bien jusqu'à l'introduction d'une date de naissance au 29 février.
J'utilise la formule suivante : =SI(C49<>"";(DATEDIF(C49;AUJOURDHUI();"Y"));""), la cellule C49 contenant la date de naissance au format date longue.
Quand je mets 29/02/1980, ma formule renvoie #VALEUR!

J'ai beau cherché sur le net, je ne trouve pas d'explication à mon problème.

Je suis en excel 2016.

Quelqu’un aurait-il une solution ?

Merci pour votre aide - Sophie

Configuration: Windows / Firefox 88.0

4 réponses

PapyLuc51 Messages postés 3798 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 29 novembre 2022 1 197
1 mai 2021 à 16:44
A ce moment là ajouter une alerte en cas d'erreur de date

=SI(C49<>"";SIERREUR(DATEDIF(C49;AUJOURDHUI();"y");"date inexistante");"")

ou autre alerte au choix

Cordialement
1
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 283
1 mai 2021 à 13:27
Bonjour*
difficile de vous répondre, testée chez moi, cette formule renvoie bien 41 avec 29/2/61980 en C49
vérifiez votre format date, et sinon dites nous en plus!!
crdlmnt
0
Bonjour,
Je viens de découvrir Excel 2016 et je ne trouve pas la fonction Datedif dans les menus...
Où se cache-t-elle ?
Merci d'avance,
Cordialement.
0
Mike-31 Messages postés 18113 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 25 novembre 2022 5 013 > eugene-92
Modifié le 1 mai 2021 à 14:48
DATEDIF est une fonction cachée d'Excel, il suffit de la saisir
=DATEDIF(date_début;date_fin;unité_de_temps)
dans unité de temps tu peux choisir de compter les année "y",
les mois "m"
ou les mois résiduels d'une année incomplète par rapport à la date de départ "ym"
0
eugene-92 > Mike-31 Messages postés 18113 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 25 novembre 2022
1 mai 2021 à 15:30
Salut Mike,
Avez vous essayé d'inscrire la fonction Datedif() sur un Excel 2016 ? Pour moi, cela ne marche pas...
0
PapyLuc51 Messages postés 3798 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 29 novembre 2022 1 197 > eugene-92
Modifié le 1 mai 2021 à 15:46
Mes salutations à tous

Si DATEDIF() ne fonctionne pas alors (cellule au format nombre sans décimale)

=(AUJOURDHUI()-C49)/365,25

Cordialement
0
eugene-92 > PapyLuc51 Messages postés 3798 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 29 novembre 2022
1 mai 2021 à 17:39
Bonjour Papy Luc,
Merci de la formule. Mais c'est tout de même étonnant qu'il n'y ait pas une fonction genre Datedif() ou similaire dans Excel 2016...
Cordialement.
0
Mike-31 Messages postés 18113 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 25 novembre 2022 5 013
1 mai 2021 à 13:30
Bonjour,

tu dois certainement avoir ta cellule C49 formatée en texte ou une erreur de saisie du genre espace dans ta saisie
Efface ta cellule et ressaisi ta valeur voir
0
Sopie31 Messages postés 47 Date d'inscription samedi 17 août 2013 Statut Membre Dernière intervention 1 mai 2021
1 mai 2021 à 16:26
Merci pur vos retours.
En fait j'ai trouvé...
Je vous avais donné comme exemple 29/02/1980 mais en fait la date de naissance qu'on me demande de rajouter est 29/02/1982 et non 29/02/1980, et là ça ne marche pas. Mais oui 1982 n'est tout simplement pas bissextile ! Donc la date de naissance communiquée n'est pas bonne.
Désolée pour le dérangement.
Problème résolu pour moi.

Sophie
0