Excel : DATEDIF avec 29 février [Résolu]

Signaler
Messages postés
47
Date d'inscription
samedi 17 août 2013
Statut
Membre
Dernière intervention
1 mai 2021
-
Messages postés
17343
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 mai 2021
-
Bonjour,

J'ai un tableau excel avec des dates de naissance et le calcul automatique de l'âge de la personne. Tout marchait très bien jusqu'à l'introduction d'une date de naissance au 29 février.
J'utilise la formule suivante : =SI(C49<>"";(DATEDIF(C49;AUJOURDHUI();"Y"));""), la cellule C49 contenant la date de naissance au format date longue.
Quand je mets 29/02/1980, ma formule renvoie #VALEUR!

J'ai beau cherché sur le net, je ne trouve pas d'explication à mon problème.

Je suis en excel 2016.

Quelqu’un aurait-il une solution ?

Merci pour votre aide - Sophie

Configuration: Windows / Firefox 88.0

4 réponses

Messages postés
3248
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
9 mai 2021
910
A ce moment là ajouter une alerte en cas d'erreur de date

=SI(C49<>"";SIERREUR(DATEDIF(C49;AUJOURDHUI();"y");"date inexistante");"")

ou autre alerte au choix

Cordialement
Messages postés
26015
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
11 mai 2021
5 920
Bonjour*
difficile de vous répondre, testée chez moi, cette formule renvoie bien 41 avec 29/2/61980 en C49
vérifiez votre format date, et sinon dites nous en plus!!
crdlmnt
Messages postés
3248
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
9 mai 2021
910 > eugene-92
Mes salutations à tous

Si DATEDIF() ne fonctionne pas alors (cellule au format nombre sans décimale)

=(AUJOURDHUI()-C49)/365,25

Cordialement
>
Messages postés
3248
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
9 mai 2021

Bonjour Papy Luc,
Merci de la formule. Mais c'est tout de même étonnant qu'il n'y ait pas une fonction genre Datedif() ou similaire dans Excel 2016...
Cordialement.
Messages postés
3248
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
9 mai 2021
910 > eugene-92
C'est vraiment étonnant que datedif() ne fonctionne pas pourtant dans la fiche Office 2016 est mentionné. Certainement un erreur quelque part sur ton fichier.

Cordialement
>
Messages postés
3248
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
9 mai 2021

Bonsoir,
Je n'ai pas trouvé cette fonction sur XL16, du coup j'ai installé le logiciel complémentaire Morefunc qui possède une fonction Diffdate(), cela fonctionne, du moins pour mes premiers essais...
Messages postés
17343
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 mai 2021
4 602 > eugene-92
Re,

dans la discussion, je ne retrouve pas le post de mes explications sur la Fonction DATEDIF
Sur la version 2016 je ne sais pas, mais sur toutes les versions antérieures la syntaxe DATEDIF est une fonction cachée d'Excel qu'il suffit d'utiliser en la saisissant manuellement.

exemple
=DATEDIF(date_début;date_fin;unité_de_temps)

l'unité de temps correspond a "Y" pour année ce qui retourne le nombre d'années complètes à partir de la date de départ
"YM" – nombre de mois complets dépassant dans la période d'années complètes, les années et les jours sont ignorés
"M" – nombre des mois complets dans la période
"D" – nombre de jours complets dans la période
"MD" – nombre de jours complets dépassant le nombre de jours d'un mois complet

Y abréviation de Year soit année en Anglais
M soit Month pour mois
D pour Day ou jour

la date de fin peut être remplacée par AUJOURDHUI() pour automatiser un calcul et mis à jour jours après jours
Messages postés
17343
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 mai 2021
4 602
Bonjour,

tu dois certainement avoir ta cellule C49 formatée en texte ou une erreur de saisie du genre espace dans ta saisie
Efface ta cellule et ressaisi ta valeur voir
Messages postés
47
Date d'inscription
samedi 17 août 2013
Statut
Membre
Dernière intervention
1 mai 2021

Merci pur vos retours.
En fait j'ai trouvé...
Je vous avais donné comme exemple 29/02/1980 mais en fait la date de naissance qu'on me demande de rajouter est 29/02/1982 et non 29/02/1980, et là ça ne marche pas. Mais oui 1982 n'est tout simplement pas bissextile ! Donc la date de naissance communiquée n'est pas bonne.
Désolée pour le dérangement.
Problème résolu pour moi.

Sophie