Convertir milliers en millions

Signaler
-
Messages postés
17337
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
3 mai 2021
-
Bonjour à tous,

J'ai une colonne dans excel avec des montants :

150 000 € HT
170 000 € HT
800 000 € HT
1 500 000 € HT
2 300 000 € HT

Je souhaiterais convertir les montants qui arrivent au million de la façon suivante :

150 000 € HT
170 000 € HT
800 000 € HT
1,5 M€ HT
2,3 M€ HT


et appliquer cela à toute la colonne.

Avez-vous l'astuce ?

Merci

4 réponses

Messages postés
31772
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
3 mai 2021
7 618
Bonjour,

Avec une cellule contenant un nombre, on peut utiliser un format personnalisé comme :
[<999950]# ##0" € HT";[<999950000]0,0  " M€ HT";0,0   " G€ HT"


ou utiliser aussi des k€ :
[<999950]0 " k€ HT";[<999950000]0,0  " M€ HT";0,0   " G€ HT" 


Messages postés
17337
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
3 mai 2021
4 585
Bonjour,

Une saisie 150 000 € HT sera considérées comme texte et plus compliqué à exploité.

Pour cela il faut que tes valeurs soient saisies en format numérique sans espace manuel et créer un format personnalisé.
exemple saisir simplement les valeurs 1500000
créer ce format personnalisé pour que la ou les valeurs soient garde leurs format numérique
# ##0,00 € "HT"


A partir de la dans une colonne écrire ce genre de formule

=SI(A2>=1000000;A2/1000000;"")

et pour ce résultat créer ce format personnalisé
0,00" M€ HT" 
Bonjour vous deux,

Alors j'ai essayé la solution de Mike mais j'ai un petit soucis quand je l'applique :

1ere colonne :
1 400 000 € HT
1 200 000 € HT
800 000 € HT

2ème colonne :
1,4 M€ HT
1,2 M€ HT
"rien ne s'affiche"

Quand j'applique la formule, pour les montants égales ou supérieurs à 1 millions, ça fonctionne, par contre pour les autres, il n'y a rien qui s'affiche. Pour rappel, pour les montants inférieurs à 1 millions, je souhaiterais laisser le format initial (soit 800 000 € HT dans la 2ème colonne)

J'ai un problème de formule ? J'ai utilisé celle-ci de Mike : =SI(A2>=1000000;A2/1000000;"")
Messages postés
17337
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
3 mai 2021
4 585
Re,

As tu testé la proposition jee pee que je salue