Calendrier [Résolu]

Signaler
Messages postés
12
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
22 avril 2021
-
Messages postés
12
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
22 avril 2021
-
Pourquoi cette formule ne marche t'elle pas en S3 alors qu'il n'y a qu'en O3 que la réponse est positive ??????

=SI(L3>1;1;0)+SI(O3>1;1;0)+SI(R3>0;1;0)

Ci joint fichier: https://www.cjoint.com/c/KDulU6NZg8j

4 réponses

Messages postés
26015
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
11 mai 2021
5 920
Bonjour
on ne voit pas très bien ce que vous voulez faire, ni comment ça peut fonctionner
votre formule additionne 1 chaque fois que L,O R sont supérieurs à 1, hors il n'y a qu'en R que la formule peut donner une valeur supérieure à 1, puisque L et 0 O ne peuvent renvoyer que 1 ou ""
Précisez ce que vous cherchez, mais peut-être vaut il mieux mettre >0
Par ailleurs
  • si vous voulez détecter sans problème la valeur gauche de L, O, R mieux vaut passer ces colonnes en format texte
  • si vous voulez utiliser la grandeur définie par GAUCHE dans votre formule en S, numérisez la dans la formule en la multipliant par 1:

=SI(L3*1>1;1;0)+SI(O3*1>1;1;0)+SI(R3*1>0;1;0)

crdlmnt
Messages postés
12
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
22 avril 2021

Effectivement, à la relecture, je n'ai pas été très clair !
Je m'explique...
Les colonnes L, O et R intitulées "T" comme "terrain" sont celles qui recueillent le numéro du terrain occupé à savoir 1, 2 ou 3 pour les catégories Nationale 3, Promotion A et promotion B.

Je cherche donc à ce que la colonne S m'affiche le nombre de terrain occupé: 1, 2, 3 ou plus car ma salle ne dispose que de 3 terrains !

J'espère avoir été plus explicite !

Le fichier joint reste le même ! Voir ci-dessus !

Merci de votre aide

Emile
Messages postés
26015
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
11 mai 2021
5 920
Alors peut être simplement:
=SI(L3<>"";1;0)+SI(O3<>"";1;0)+SI(R3<>"";1;0)
qui renverra un 0 si aucune salle n'est affectée, 0 que vous pouvez masquer via les options Excel
ou alors en écrivant, un peu plus compliqué:
=SI(ET(L3="";O3="";R3="");"";SI(L3<>"";1;0)+SI(O3<>"";1;0)+SI(R3<>"";1;0))
Mais les 0 sont nécessaires dans ce type d'addition qui m'admet pas de sommer des ""
crdlmnt
Ps: mais si toutefois il y a erreur en R3 et que la formule devrait renvoyer 1 plutôt que 3 (pourquoi 3 ?), il est tout simple d'écrire la somme des 1 avec:
=SOMME(L3;O3;R3)
qui ne pose pas de problème avec les""

Messages postés
12
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
22 avril 2021

Apparemment vous avez trouvé la solution et je vous remercie !

Désolé pour le retard dans la réponse !

Merci et encore BRAVO !!

Emile