Excel - Détermination nombre valeurs différentes

Résolu/Fermé
NicoK_98 Messages postés 3 Date d'inscription mercredi 14 avril 2021 Statut Membre Dernière intervention 14 avril 2021 - Modifié le 14 avril 2021 à 18:27
NicoK_98 Messages postés 3 Date d'inscription mercredi 14 avril 2021 Statut Membre Dernière intervention 14 avril 2021 - 14 avril 2021 à 19:03
Bonsoir,

Je voudrais déterminer le nombre de valeurs identique dans une colonne en fonction d'un code article qui se trouve dans une autre colonne.

Pour être plus claire j'ai mis le pb en pièce jointe.

Sur les topics déjà existant, ils cherchent les valeurs identiques d'une colonne sans aller plus loin, cependant, j'ai besoin de prendre en compte une autre colonne.

Grâce aux topics existant, maintenant j'arrive à calculer le nombre de valeurs identique au total (colonne D), je trouve 8 (J4), cependant j'aimerai avoir une formule pour retrouver ce que j'ai mis en rouge et qui prendrait en compte la colonne B

En d'autres termes, connaître le nombre de device différent pour CE101, CE102, CE103...

En espérant avoir été claire.


Merci d'avance !

4 réponses

Raymond PENTIER Messages postés 56854 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 5 décembre 2022 17 183
14 avril 2021 à 18:30
Bonjour.

Comme toujours, un court fichier Excel vaut mieux qu'un long message, qu'une belle image ou que les deux ensemble ...
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers
Il existe aussi :
1) https://mon-partage.fr/
2) https://www.transfernow.net/

0
NicoK_98 Messages postés 3 Date d'inscription mercredi 14 avril 2021 Statut Membre Dernière intervention 14 avril 2021
14 avril 2021 à 18:41
0
ALS35 Messages postés 963 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 6 décembre 2022 111
14 avril 2021 à 18:55
Bonjour,

Une proposition en H4 et à recopier vers le bas :
=SOMMEPROD((1/NB.SI.ENS($B$4:$B$24;$B$4:$B$24;$D$4:$D$24;$D$4:$D$24))*($B$4:$B$24=G4))


et en J4 plutôt :
=SOMMEPROD(1/NB.SI($D$4:$D$24;D4:D24))


Cordialement
0
NicoK_98 Messages postés 3 Date d'inscription mercredi 14 avril 2021 Statut Membre Dernière intervention 14 avril 2021
14 avril 2021 à 19:03
Merci beaucoup !
0