Tableau filtrage de données

Fermé
LEFLOHIC Messages postés 17 Date d'inscription vendredi 7 août 2009 Statut Membre Dernière intervention 13 avril 2021 - 13 avril 2021 à 18:50
via55 Messages postés 14417 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 25 mai 2024 - 13 avril 2021 à 23:48
Bonjour je suis en train de créer un tableau qui reprend des données de plusieurs feuilles. Sur ce tableau je voudrais trier des dates à traiter en urgence. Mon souci est que ces dates se trouvent sur plusieurs colonnes. Pour le tri sur une colonne pas de souci mais pour l'ensemble du tableau impossible de trouver une formule . Quelqu'un peut-il me dire si cela est possible . Si oui quelle formule utilisée . Merci

3 réponses

via55 Messages postés 14417 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 25 mai 2024 2 707
Modifié le 13 avril 2021 à 23:48
Vu le nombre de colonnes j'ai crée 3 fonctions personnalisées qui permettent dans les 3 colonnes rajoutées à droite d'inscrire des 1 lorsque dans la ligne il y a une date de la semaine en cours ou une date de la semaine prochaine ou une date du mois prochain (comme tes MFC)

https://www.cjoint.com/c/KDnvV5AP6UO

Les fonctions s'utilisent comme toute fonction Excel et selon la syntaxe =nom de la fonction(plage à traiter) ex : =sem_actu(C5:AB5) mis en AC2

Cliquer sur un onglet puis Visualiser le code pour ouvrir l'éditeur VBA puis aller dans Module1 pour voir le code des 3 fonctions avec commentaires

Ensuite il ne reste bien sûr qu'à filtrer tout le tableau selon les 1 d'une colonne pour visualiser les RV de la semaine ou de la semaine prochaine ou du mois prochain

Cdlmnt
Via

1
via55 Messages postés 14417 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 25 mai 2024 2 707
13 avril 2021 à 19:30
Bonsoir

Tout dépend le nombre de colonnes avec des dates et quel critères
Avec par exemple des dates sur 3 colonnes C, G et H par exemple et à relever les dates avant juillet tu peux très bien dans une colonne supplémentaire avec une formule SI(OU faire mettre une croix en regard des lignes avec date à retenir (style =SI(OU(C2 <DATEVAL("1/7/21");G2 <DATEVAL("1/7/21");H2 <DATEVAL("1/7/21"));"X";"")
Ensuite il ne reste qu'à filtrer le tableau sur la colonne avec les X

Sinon il faut peut être passer par une macro mais impossible d'en dire plus sans connaître la structure exacte de ton tableau
Poste un exemple de ton fichier sur cjoint.com ou mon-partage.fr, copie le lien créé et reviens le coller ici qu'on puisse avoir une base sérieuse de réflexion

Cdlmnt
Via

0
LEFLOHIC Messages postés 17 Date d'inscription vendredi 7 août 2009 Statut Membre Dernière intervention 13 avril 2021
13 avril 2021 à 20:09
0