Formule case à cocher... ne fonctionne pas [Résolu]

Signaler
Messages postés
11
Date d'inscription
mardi 23 mars 2021
Statut
Membre
Dernière intervention
9 avril 2021
-
Messages postés
11
Date d'inscription
mardi 23 mars 2021
Statut
Membre
Dernière intervention
9 avril 2021
-
Bonjour,

Bonjour,

J'ai crée une formule qui fonctionne à moitié... :(

=SI(ET(ET($B$6="X";SOMME($B$7:$B$11)=0);SOMME($B$1:$B$5)=0);"OK";"Attention case cochée")

Explication de mon tableau, colonne A à C, lignes 1 à 11 :
Colonne B, je reprends les données de la colonne A, à partir du caractère 8 grâce à la formule :
=SI(STXT(A1;8;20)="";0;CNUM(STXT(A1;8;20)))
, et ce sur 11 lignes, SAUF ligne B6 (je ne peux pas modifier l'emplacement de la ligne 6).
Les données seront forcément des montants.
S'il n'y a pas de saisie de montant dans la colonne A, la colonne B sera remplie en 0 significatif SAUF B6.

B6 = =SI(STXT(A6;8;20)="";0;"X")

Si le caractère 8 de A6 est coché, alors B6 aura un X.

Dans la colonne C, je cherche à rentrer un contrôle qui dira :

Concrètement, si la case est cochée, cela veut dire que l'on veut rendre un formulaire vide, tous les champs du formulaire ne seront pas remplis(0 significatif), sinon erreur.

La formule que je cherche :
Dans mon tableau, je cherche la formule :

Si B6 = X est coché, alors B1 à B5 = 0(significatif) et B7 à B11 = 0. Si c'est juste OK, sinon code erreur "attention case cochée". Si X n'est pas coché : OK.

Ma formule fonctionne lorsque B6 est coché et B1 à B5 puis B6 à B11 = 0, j'ai bien OK.
Lorsque j'ai B6 coché et que je rentre un montant sur les autres lignes, j'ai OK... alors que tous les autres champs doivent être vides.
Enfin, quand je ne coche pas B6 car ce n'est pas un formulaire vide, et que je veux remplir les autres champs, cela me met erreur.... à tort.

Si quelqu'un pouvait regarder ma formule... et me dire où je me suis trompée...

Merci beaucoup d'avance !

2 réponses

Messages postés
53598
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
15 644
Bonjour Panda.

Je suis un peu perplexe devant ta formule et tes explications :

Quand tu écris
=SI(
ET(
ET($B$6="X";SOMME($B$7:$B$11)=0
)
;SOMME($B$1:$B$5)=0);...
c'est exactement comme si tu écrivais
=SI(ET($B$6="X";SOMME($B$7:$B$11)=0;SOMME($B$1:$B$5)=0);...

Et c'est quoi, un zéro significatif ?

"Si B6 = X est coché, alors B1 à B5 = 0(significatif) et B7 à B11 = 0" -> Non, ce n'est pas ce que dit ta formule ... Ta formule signifie "Si B6="X" et SOMME(B7:B11) et SOMME(B1:B5))=0 alors "OK" ; donc si ces 3 conditions sont remplies simultanément, alors on affiche "OK".

"Lorsque j'ai B6 coché et que je rentre un montant sur les autres lignes, j'ai OK" -> Tu rentres probablement des montants en format TEXTE !

Tant qu'on ne pourra pas travailler sur ton fichier Excel (et pas sur une simple image), il nous sera difficile de t'aider davantage ...
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers
Il existe aussi :
1) https://mon-partage.fr/
2) https://www.transfernow.net/

Messages postés
11
Date d'inscription
mardi 23 mars 2021
Statut
Membre
Dernière intervention
9 avril 2021

Bonjour

Merci Raymond :) de m'avoir répondue !

Je vais clôturer ce post car en relisant de plus près le contrôle que je dois créer, et bien, il me manquait des éléments... donc je dois refaire une formule différente, que je sais faire.

Merci !