Formule qui affiche résultat faux [Résolu]

Signaler
Messages postés
7
Date d'inscription
vendredi 16 novembre 2018
Statut
Membre
Dernière intervention
24 mars 2021
-
Messages postés
25952
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 avril 2021
-
Bonjour.Probléme avec la formule si(c3>=b3;1;0) qui affiche toujours 1.Toutes les valeurs de (C3:C18) supérieures a b3 doivent afficher 1 et 0 pour les autres.J'essaie d'envoyer un fichier,mais je ne trouve pas.Peut être une histoire d'espace ?
Merci

6 réponses

Messages postés
25952
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 avril 2021
5 866
Bonjour
et vous avez bien bloqué le B3 pour tirer la formule? sur la hauteur
=SI(C23>=$B$3;1;0)
ça devrait fonctionner
crdlmnt
Messages postés
7
Date d'inscription
vendredi 16 novembre 2018
Statut
Membre
Dernière intervention
24 mars 2021

Bonjour,oui le b3est bien bloqué et que des 1 partout.Pas moyen de joindre un fichier?
Messages postés
25952
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 avril 2021
5 866
Si voyez ici et revenez coller le lien créé sur le site
https://mon-partage.fr
Messages postés
7
Date d'inscription
vendredi 16 novembre 2018
Statut
Membre
Dernière intervention
24 mars 2021

Messages postés
25952
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 avril 2021
5 866
éh bé ?
  • D'une part votre B3 n'est pas bloqué. Il devient B4 sur ligne 4, B5 sur ligne 5 etc

écrivez bien $B$3 avec le B encadré par les signes $
  • D'autre part je ne sais pas d'où viennent vos valeurs en C, mais ce sont des textes . Pour vérifier: format de cellule / alignement Horizontal /standard les textes s'affichent à gauche et les num à droite; Dans votre modèle ils restent à gauche

pour réparer ça
  • copier une cellule vide
  • sélectionnez le champ et collage spécial "addition"

au final ça donne ça (avec les valeurs de C à droite dans les cellules)
https://mon-partage.fr/f/Bz8XDQ4M/
crdlmnt
Messages postés
7
Date d'inscription
vendredi 16 novembre 2018
Statut
Membre
Dernière intervention
24 mars 2021

Merci,pour le b3 non bloqué,c'est une etourderie!La formule fonctionne bien maintenant.
Bonne soirée.
Messages postés
25952
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 avril 2021
5 866
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt