Calcul Excel avec double condition [Résolu]

Signaler
Messages postés
3
Date d'inscription
dimanche 31 janvier 2021
Statut
Membre
Dernière intervention
16 mars 2021
-
Messages postés
3
Date d'inscription
dimanche 31 janvier 2021
Statut
Membre
Dernière intervention
16 mars 2021
-
Bonjour,
Quelle est la formule qui me permet de réaliser le calcul suivant:
Si A<100 Alors B=30% de 100, mais si A>100 alors B =30% de A dans la limite de 100.

Merci d'avance
Bruno

Configuration: Android / Chrome 89.0.4389.86

3 réponses

Messages postés
1063
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
23 mars 2021
225
Bonjour,
Avec la valeur en A1
=si(A1<100;30;si(a1*0,3>100;100;a1*0,3))
Messages postés
54055
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 juin 2021
16 058
Bonjour Bruno.

Ta demande ne veut pas dire grand-chose ...
il me semble que tu voulais expliquer
Si A<100 alors B=30% de A, mais si A>100 alors B=30% de A dans la limite de 100
... ce qui s'écrit plus simplement
B=30% de A dans la limite de 100
...

La formule serait tout bêtement =SI(A1<100;A1*30%;100)
ou alors, un peu plus subtilement =MIN(A1*30%;100)

Cordialement.
Messages postés
3
Date d'inscription
dimanche 31 janvier 2021
Statut
Membre
Dernière intervention
16 mars 2021

Bonjour,
Merci
Bonne retraite sous les tropiques