Si.conditions

Résolu/Fermé
vivi - 10 mars 2021 à 11:06
 vivi - 11 mars 2021 à 12:28
Bonjour Tous,

J'ai besoin d'un coup de main pour une formule à trois conditions, je m'en sors pas !

L'idée :

si la somme de plusieurs cellules est égal à 0, alors le résultat sera 0
si la somme de plusieurs cellules est inférieur à 39220 alors le résultat est 1000
si la somme de plusieurs cellules est supérieurs à 39220 alors le résultat est 1500

j'ai essayé ça : =SI.CONDITIONS((J11)+(J13:J22)="0";0;(J11)+(J13:J22)="39220";1000;(J11)+(J13:J22)>39220;"1500")

et pleins d'autres formules, mais je m'en sors pas...

Est-ce que qqun peut me donner un coup de main ?

Merci-merci-merci mille fois d'avance !



Configuration: Windows / Chrome 88.0.4324.190

4 réponses

DjiDji59430
Messages postés
3608
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
10 août 2022
543
Modifié le 10 mars 2021 à 11:16
Bonjour à tous,

essaye
=SI.CONDITIONS(((J11)+(J13:J22))=0;0;((J11)+(J13:J22))<=39220;1000;((J11)+(J13:J22))>39220;1500)
On ne met jamais de guillemets a des nombres, ça les transforme en texte et donc tu ne peux pas leur faire faire des opérations mathématiques.

Crdlmt
0
Bonjour DjiDji59430 !

Merci pour la réponse ultra rapide ;o)

Effectivement, les guillemets n'aidaient pas. Cependant, la formule n'est toujours pas correct et je ne comprends toujours pas l'erreur.
Elle me renvoie à " #NOM? "
Une idée à tout hasard ?
En tout cas, merci beaucoup pour l'aide !
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 266
10 mars 2021 à 12:50
Bonjour
ne connais pas SI.CONDITIONS, mais on pourrait écrire plutôt:


=SI(J11+SOMME(J13:J22)=0;0;SI(J11+SOMME(J13:J22)=39200;39200;SI(J11+SOMME(J13:J22)>39200;1500;"")))
(qui renvoie en final une cellule "blanche" si aucune condition est remplie)
crdlmnt
crdlmnt
0
DjiDji59430
Messages postés
3608
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
10 août 2022
543
10 mars 2021 à 19:15
Re vivi
La formule fonctionne parfaitement sous excel 365.
On peut supposer que tu travailles sous cette version, ou 2019
Comme tu n'as pas donné ta version ......

Crdlmt
Bonjour Vaucluse
0
salut DjiDji59430, salut Vaucluse !

je vous remercie infiniment : j'ai pu tester avec la solution de Vaucluse et tout est parfait ainsi
mille mercis, je pataugeais sans votre support !
bonne journée tous
vivi
0