Mettre un format personnalisé "aa" sous condition

Résolu/Fermé
07coba
Messages postés
3
Date d'inscription
vendredi 26 février 2021
Statut
Membre
Dernière intervention
26 février 2021
- 26 févr. 2021 à 10:24
07coba
Messages postés
3
Date d'inscription
vendredi 26 février 2021
Statut
Membre
Dernière intervention
26 février 2021
- 26 févr. 2021 à 11:04
Bonjour,

j'ai une colonne A avec des dates de naissances, une colonne B qui donne l'age par la formule
=SI(ESTVIDE(A2);"";(AUJOURDHUI())-A2) dont les cellules sont au format personnalisé "aa".

Je souhaite utiliser ces ages (colonne B) pour y placer la condition suivante
si age <26, alors format jaune et si age >45, alors format bleu

Je vous remercie pour votre aide.



Configuration: Windows / Chrome 88.0.4324.190

2 réponses

Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
168
26 févr. 2021 à 10:56
Bonjour,

avec des MFC :


0
07coba
Messages postés
3
Date d'inscription
vendredi 26 février 2021
Statut
Membre
Dernière intervention
26 février 2021

26 févr. 2021 à 11:01
le soucis est que la formule affiche le total des jours depuis 1900 par défaut et non le chiffre de l'age, la condition ne s'applique donc pas sur l'age affiché mais sur le résultat des jours, donc tous suppérieur à 45.
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 265
Modifié le 26 févr. 2021 à 11:03
Bonjour
saisissez le champ à traiter (si on commence en A2)
mise en forme conditionnelle / nouvelle règle / utiliser une formule...."
entrez cette formule
=AUJOURDHUI()<DATE(ANNEE($A2)+26;MOIS($A2);JOUR($B2))
pour le bleu

=AUJOURDHUI()>DATE(ANNEE($A2)+45;MOIS($A2);JOUR($B2))
pour le jaune

et remplacer les > ou < par >= ou <= si vous voulez inclure les limites dans le formatage
crdlmnt



0
07coba
Messages postés
3
Date d'inscription
vendredi 26 février 2021
Statut
Membre
Dernière intervention
26 février 2021

26 févr. 2021 à 11:04
parfait ! je vois que c'est le texte ANNEE MOIS JOUR qui manquait dans ma formule !
merci !
0