Problème de formule

Résolu/Fermé
Minouche - 25 févr. 2021 à 08:46
Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
- 25 févr. 2021 à 09:32
Bonjour,

J'ai un tableau dans lequel je tiens les acomptes payés par les clients.

J'ai inscris le montant des acomptes attendus dans les colonnes "acompte1" "acompte2"....et dans les colonnes "date1" "date2" la date à laquelle l'acompte concerné a été payé.

Je cherche une formule SI qui me permettrait de calculer le total restant dû à condition que dans la colonne date il y ai une date et donc que le montant de l'acompte concerné soit pris en compte.

Impossible de trouver la bonne formule.

Quelqu'un peut-il m'aider ?

Merci


Configuration: Windows / Chrome 88.0.4324.182

6 réponses

Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
168
25 févr. 2021 à 08:53
Bonjour,

vous ne nous indiquez pas dans quelles colonnes sont vos données.

Il faudrait partager votre fichier, ou une copie de celui-ci anonymisé via https://www.cjoint.com/
Et ensuite revenir ici coller le lien généré.

En attendant, un début de solution, en considérant que les dates soient en colonne A :

=SI(A1<>"";votre calcul;"")
0
Bonjour,

Oups, alors voici le lien avec le tableau.

https://www.cjoint.com/c/KBzh4q1qqdS
0
Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
168
Modifié le 25 févr. 2021 à 09:07
Message à ne pas prendre en compte, je n'ai pas vu de suite le poste #3 ^^
0
Minouche > Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022

25 févr. 2021 à 09:16
Je suis maladroite j'ai indiqué la formule suivante dans la colonne S "Total encore dû"

=SI((ESTDATE(H2)),SI(ESTDATE(K2)),SI(ESTDATE(N2)),SI(ESTDATE(Q2));(F2-G2-J2-M2-P2);"")

Cela fait très longtemps que je n'ai pas fais de formule :-(
0
Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
168 > Minouche
25 févr. 2021 à 09:22
Vous vous êtes compliquée la vie ;-)

Solution au post #6
0
Les acomptes sont en colonnes CA AC 1 et CA AC 2 et CA AC 3
La formule attendue est dans la colonne Total encore dû

Je souhaite dans cette cellule que SI dans les cellules Date AC1 et Date AC2 et Date AC 3 est inscrit une date de paiement alors le total restant dû est égal au CA TTC moins les acomptes CA AC1... sinon si pas de date dans la cellule alors ne pas prendre le montant du CA AC1 etc

C'est un peu compliqué à expliquer
0
Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
168
Modifié le 25 févr. 2021 à 09:20
à tester en S2, d'après vos infos :
=F2-(SI(H2<>"";G2;0)+SI(K2<>"";J2;0)+SI(N2<>"";M2;0))
0
Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
168
25 févr. 2021 à 09:24
Votre fichier modifié :

https://www.cjoint.com/c/KBziyCVggPb
0
Je me suis trompée cela fonctionne super bien !!!
Merci beaucoup pour votre aide précieuse.

Excellente journée à vous.
0
Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
168 > Minouche
25 févr. 2021 à 09:32
Si cela vous convient, n'oubliez pas de passer votre sujet en [Résolu]

Bonne journée à vous.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
J'ai testé mais ce n'est pas encore tout à fait ça puisque dans certaines colonnes où la date est indiqué cela n'a pas pris en compte le montant de l'acompte.

https://www.cjoint.com/c/KBziAZ6EhES
0
Yoyo01000
Messages postés
1639
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
7 mars 2022
168
25 févr. 2021 à 09:29
C'est de ma faute, j'ai oublié une paire de ()

J'ai modifié la formule dans le post #6 et je vous ai joint votre fichier modifié dans le post #8
0
Oui super j'ai vu !

Merci beaucoup :-)

Très bonne journée à vous.
0