Recherche un formule

Résolu/Fermé
Laurence33480
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021
- 24 févr. 2021 à 18:59
Laurence33480
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021
- 24 févr. 2021 à 22:43
Bonsoir,

Voici ma demande :
- 5 colonnes à additionner
- avec pour chacune d'elle la formule suivante : si la cellule est égale ou supérieur à 0 c'est 0 sinon 1

Mon petit schéma :
Colonne A1(1)+ Colonne A2 (3) + Colonne A3 (0) + Colonne A4 (1)+ Colonne A5 (0) = Colonne A6 (Total)
Si(A1<=0;"0 ";"1")+(A2<=0;"0 ";"1")+(A3<=0;"0 ";"1")+(A4<=0;"0 ";"1")+(A5<=0;"0 ";"1")= 3

Merci pour votre aide!

11 réponses

Le Pingou
Messages postés
11107
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
10 août 2022
1 299
24 févr. 2021 à 19:34
Bonjour,
Au passage cela devrait faire l'affaire:
cellule A6
 =NB.SI(A1:A5;"<>0") 

0
Laurence33480
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021

24 févr. 2021 à 19:51
Bonsoir le pingou c'est top !

Par contre si je souhaite la répéter sur toute la colonne ce n'est pas possible ?

Ligne 1 =NB.SI(A1:A5;"<>0")
Ligne 2 =
Ligne 3 =
etc...

Grand merci à toi et belle soirée
0
Nil_0204
Messages postés
5
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
25 février 2021

24 févr. 2021 à 19:55
As tu essayé de double cliquer en bas à droite de ta cellule ?
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 265
24 févr. 2021 à 19:59
Bonsoir (et salut ami Le Pingou)
vous parlez de colonne ou de ligne ?
vous voulez calculez quoi après ligne 1?
crdlmnt
0
Laurence33480
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021

24 févr. 2021 à 20:20
0
Laurence33480
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021

24 févr. 2021 à 20:22
Bonsoir,

La colonne Zone 3 à répéter jusqu'en bas dès que j'aurai saisie les colonnes Lundi, Mardi etc...

Grand merci
0
Laurence33480
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021

24 févr. 2021 à 20:13
Bonsoir Nil,

Lorsque je copie la formule en dessous elle ne fonctionne pas je dois impérativement la re saisir...

As-tu une solution

Grand merci
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Nil_0204
Messages postés
5
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
25 février 2021

24 févr. 2021 à 20:17
Il ne faut pas la copier justement. Normalement le "double clic" suffit à recopier la formule en tenant compte de la variabilité des lignes. Sinon essaye d'étirer la formule ?
0
Laurence33480
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021

24 févr. 2021 à 20:28
Mon cher Nil cela ne fonctionne pas où suis-je trop fatiguée...

Voici en étirant ma formule !
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 265
Modifié le 24 févr. 2021 à 21:06
D'après votre tableau, il semblerait que la formule devrait être:
=NB.SI(A5:E5;"<>0")
si rien ne m'échappe dans vos affiche d'entête de lignes et colonnes?

Par ailleurs, une cellule vide n'est pas reconnue comme 0 par Excel, donc la formule compte 5 si toutes sont vides, puisque différentes de0
donc essayez avec:
=5-NB.SI(A1:A5;0)-NB.SI(A1:A5;"")

ou alors bien plus simplement si vous n'avez jamais de valeur négative dans le champ:
=NB.SI(A1:A5;">0")


crdlmnt

0
Le Pingou
Messages postés
11107
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
10 août 2022
1 299
Modifié le 24 févr. 2021 à 21:28
Bonjour,
Je vous ai fabriqué un petit exemple et aussi une modification de la formule pour prendre en compte les lignes vides.
Voir le fichier : https://www.cjoint.com/c/KByutwXPax0
Pour copier la formule vers le bas , sélectionner la première cellule qui à la formule et avec le curseur sur l'angle à droite (curseur devient petite croix '+') clic appuyé et tirer vers le bas...?

Salutations.
Le Pingou
0
Laurence33480
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021

24 févr. 2021 à 22:23
GRAND MERCI LE PINGOU TU ES FORMIDABLE !

Je suis assistante indépendante depuis 1 an et si besoin d'aide je suis là !

Belle soirée ...
0
Le Pingou
Messages postés
11107
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
10 août 2022
1 299
24 févr. 2021 à 22:32
Merci, content pour vous.
On a toujours besoin d'aide.... m'est en quoi ....
merci de mettre le poste en Résolu si c'est le cas
0
Laurence33480
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021

24 févr. 2021 à 22:43
Oui désolée je suis assistante administratif (pme/particuliers et propriété vitivinicole)

ENCORE GRAND MERCI
0