Recherche un formule [Résolu]

Signaler
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021
-
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021
-
Bonsoir,

Voici ma demande :
- 5 colonnes à additionner
- avec pour chacune d'elle la formule suivante : si la cellule est égale ou supérieur à 0 c'est 0 sinon 1

Mon petit schéma :
Colonne A1(1)+ Colonne A2 (3) + Colonne A3 (0) + Colonne A4 (1)+ Colonne A5 (0) = Colonne A6 (Total)
Si(A1<=0;"0 ";"1")+(A2<=0;"0 ";"1")+(A3<=0;"0 ";"1")+(A4<=0;"0 ";"1")+(A5<=0;"0 ";"1")= 3

Merci pour votre aide!

11 réponses

Messages postés
10059
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
14 juin 2021
1 149
Bonjour,
Au passage cela devrait faire l'affaire:
cellule A6
 =NB.SI(A1:A5;"<>0") 

Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021

Bonsoir le pingou c'est top !

Par contre si je souhaite la répéter sur toute la colonne ce n'est pas possible ?

Ligne 1 =NB.SI(A1:A5;"<>0")
Ligne 2 =
Ligne 3 =
etc...

Grand merci à toi et belle soirée
Messages postés
5
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
25 février 2021

As tu essayé de double cliquer en bas à droite de ta cellule ?
Messages postés
26069
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 juin 2021
5 958
Bonsoir (et salut ami Le Pingou)
vous parlez de colonne ou de ligne ?
vous voulez calculez quoi après ligne 1?
crdlmnt
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021

Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021

Bonsoir,

La colonne Zone 3 à répéter jusqu'en bas dès que j'aurai saisie les colonnes Lundi, Mardi etc...

Grand merci
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021

Bonsoir Nil,

Lorsque je copie la formule en dessous elle ne fonctionne pas je dois impérativement la re saisir...

As-tu une solution

Grand merci
Messages postés
5
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
25 février 2021

Il ne faut pas la copier justement. Normalement le "double clic" suffit à recopier la formule en tenant compte de la variabilité des lignes. Sinon essaye d'étirer la formule ?
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021

Mon cher Nil cela ne fonctionne pas où suis-je trop fatiguée...

Voici en étirant ma formule !
Messages postés
26069
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 juin 2021
5 958
D'après votre tableau, il semblerait que la formule devrait être:
=NB.SI(A5:E5;"<>0")
si rien ne m'échappe dans vos affiche d'entête de lignes et colonnes?

Par ailleurs, une cellule vide n'est pas reconnue comme 0 par Excel, donc la formule compte 5 si toutes sont vides, puisque différentes de0
donc essayez avec:
=5-NB.SI(A1:A5;0)-NB.SI(A1:A5;"")

ou alors bien plus simplement si vous n'avez jamais de valeur négative dans le champ:
=NB.SI(A1:A5;">0")


crdlmnt

Messages postés
10059
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
14 juin 2021
1 149
Bonjour,
Je vous ai fabriqué un petit exemple et aussi une modification de la formule pour prendre en compte les lignes vides.
Voir le fichier : https://www.cjoint.com/c/KByutwXPax0
Pour copier la formule vers le bas , sélectionner la première cellule qui à la formule et avec le curseur sur l'angle à droite (curseur devient petite croix '+') clic appuyé et tirer vers le bas...?

Salutations.
Le Pingou
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021

GRAND MERCI LE PINGOU TU ES FORMIDABLE !

Je suis assistante indépendante depuis 1 an et si besoin d'aide je suis là !

Belle soirée ...
Messages postés
10059
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
14 juin 2021
1 149
Merci, content pour vous.
On a toujours besoin d'aide.... m'est en quoi ....
merci de mettre le poste en Résolu si c'est le cas
Messages postés
8
Date d'inscription
mercredi 24 février 2021
Statut
Membre
Dernière intervention
24 février 2021

Oui désolée je suis assistante administratif (pme/particuliers et propriété vitivinicole)

ENCORE GRAND MERCI