Multiplication sous condition [Résolu]

Signaler
-
Messages postés
2237
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
2 mars 2021
-
Bonjour,

Je voudrais faire la multiplication suivante:

Si le résultat de ma cellule F3 est supérieur à 100 alors on multiplie par 2 et si c'et supérieur ou égal à 200, on multiplie par 3.

J'ai écrit cette formule:
=IF(F3<100;F3*2;IF(F3<=200;F3*3))

Tant que le résultat est inférieur à 200 aucun problème, mais une fois que le résultat est supérieur à 200 il m'écrit FALSE.

Pourriez-vous me dire quelle erreur j'ai faite dans ma formule svp?

merci!!

2 réponses

Messages postés
2237
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
2 mars 2021
380
Bonjour
A tester
=SI(F3<100;"";SI(F3<200;SOMME(F3*2);SI(F3>199;SOMME(F3*3))))
Cordialement
Merci ça fonctionne ;)
Messages postés
23901
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
28 février 2021
6 671
Pourquoi
SOMME(F3*2)
et non pas
F3*2
tout simplement ? ;-)
Messages postés
2237
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
2 mars 2021
380 >
Messages postés
23901
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
28 février 2021

Bonjour eriiic

Une fantaisie comme une autre .
Crdlt
Messages postés
23901
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
28 février 2021
6 671
Bonjour,

Si le résultat de ma cellule F3 est supérieur à 100 alors on multiplie par 2 et si c'et supérieur ou égal à 200, on multiplie par 3.
tu dis supérieur à 100 et dans ta formule on lit <100 ?!?
Qu'est-ce qui est bon ?
Si c'est le texte, que veux-tu si inférieur à 100 ? F3 ? Ce n'est pas dit.
Ca manque de rigueur pour avoir une réponse adéquate... ;-)
eric
Tu as raison, j'ai modifié et ça fonctionne
Merci