Comparer 2 lignes excel

Signaler
-
 elect31 -
Bonjour,

1 ligne contenant les valeurs A, B,C ou D (les résultats justes d'un QCM)
ex : B A B A C D
1 autre ligne contenant les réponses de l'étudiant au QCM
ex : B B A A C D
Comment compter le score (c'est à dire le nombre de réponses justes) de la seconde ligne par rapport à la 1°?


Merci



Configuration: Windows / Firefox 85.0

7 réponses

Messages postés
2348
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
2 mars 2021
1 034
Bonsoir
=SOMMEPROD(A$1:F$1=A2:F2)

Merci de ta réponse rapide mais cela donne 0 chez moi
Moi aussi j'étais parti sur qque chose comme ça, mais ça ne donne rien.
Messages postés
2348
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
2 mars 2021
1 034 > elect31
Bonsoir
A tester
Messages postés
9680
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
3 mars 2021
2 046
Essaies alors ceci, avec SOMMEPROD, comme proposé par yclik mais en ajoutant *1 en fin de condition
=SOMMEPROD(($A$2:$E$2=A3:E3)*1)

https://www.cjoint.com/c/KBitTazbxpB

Cdlmnt
Merci. Ca fonctionne très bien avec *1.
Je n'ai pas compris pourquoi, mais merci quand même.
Messages postés
1424
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
1 mars 2021
147
Bonsoir,

un exemple :


Messages postés
1424
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
1 mars 2021
147
Je suis désolé mais ton fichier ne veut pas s'ouvrir et la réponse avec des SI() ne peut pas satisfaire s'il y a plus de 7 conditions, si je me souviens bien...???
Ce n'était qu'un exemple que je donnais . J'ai 15 questions à mon QCM
Messages postés
1424
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
1 mars 2021
147 > elect31
Il fallait le préciser de suite !

Parce du coup, les propositions de nous 3 ne peuvent vous satisfaire !

Ou alors il vous faut modifier les propositions à votre fichier...
Messages postés
9680
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
3 mars 2021
2 046
Bonjour

Un peu bourrin mais ...
https://mon-partage.fr/f/cLDRcrQe/

Cdlmnt
Effectivement, c'est un peu bourrin... j'ai besoin d'un nombre variable de questions...donc 15, 20 30 fois SI()??
Messages postés
9680
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
3 mars 2021
2 046
Bonjour

Si c'est fini, penses à mettre le sujet à résolu (en haut dans ton premier message)

Cdlmnt
Je ne vois pas comment on fait. Je n'ai pas de bouton Modifier.