EXCEL: Affiche "VRAI" au lieu du résultat [Résolu]

Signaler
Messages postés
52
Date d'inscription
samedi 3 septembre 2011
Statut
Membre
Dernière intervention
12 janvier 2021
-
Messages postés
52
Date d'inscription
samedi 3 septembre 2011
Statut
Membre
Dernière intervention
12 janvier 2021
-
Bonjour à tous,

j'ai un petit souci avec ma formule qui affiche "VRAI" au lieu du résultat en lui-même.

Voici ma formule:
=SI(N13="";I13;SI(ET(K13<>"";M13<>"");ET(I13-N13/2;J13+N13/2);ET(I13+N13/2;J13-N13/2)))

J'ai eu le même souci tout à l'heure et c'était juste un problème de parenthèse mal placée mais là, je sèche !

Merci pour votre aide.



Configuration: Windows / Firefox 84.0

3 réponses

Messages postés
30564
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
12 janvier 2021
7 216
Bonjour,

C'est que tu n'as pas mis quoi faire si vrai (et faux) derrière tes 3 ET, et qu'en plus les 2 derniers ET ne sont pas des conditions, mais des calculs. La syntaxe est globalement fausse.

Messages postés
52
Date d'inscription
samedi 3 septembre 2011
Statut
Membre
Dernière intervention
12 janvier 2021
66
Je l'ai pensé comme ceci:

=SI(N13="";I13;SI(ET(K13<>"";M13<>"");ET(I13-N13/2;J13+N13/2);ET(I13+N13/2;J13-N13/2)))

Premier ET est une condition
Deuxième ET est résultat si vrai
Troisième ET est résultat si faux

Je pensais que ça aurait fait les calculs de l'une ou l'autre condition lorsque l'une des deux aurait été atteinte.

Que devrais-je faire pour le coup ?
Messages postés
30564
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
12 janvier 2021
7 216
le ET contient des conditions
ET(condition1; condition2; condition3,...)


une condition c'est une valeur, un opérateur une valeur, ton premier ET contient bien des conditions, les autres contiennent 2 calculs

=SI(N13="";I13;SI(ET(K13<>"";M13<>"");I13-N13/2;J13+N13/2)) 


serait une formulation plus exacte, si elle répond à ce que tu veux faire
Messages postés
52
Date d'inscription
samedi 3 septembre 2011
Statut
Membre
Dernière intervention
12 janvier 2021
66
Merci Jee Pee, tu m'as bien éclairé !

En fait j'essayais de mettre tout dans la même cellule alors que je devais le faire dans deux cellule différente !

Du coup, mes deux formules (dans chacune des cellules) sont:
=SI($N13="";I13;SI(ET(K13<>"";$M13<>"");I13-$N13/2;I13+$N13/2))
=SI($N13="";J13;SI(ET(L13<>"";$M13<>"");J13-$N13/2;J13+$N13/2))

Merci encore ;-)