Cellule vierge

Signaler
-
Messages postés
53128
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
-
Bonjour,

J'ai 2 colonnes, 1 indiquant les dates de livraisons prévues et 1 autre indiquant la date de livraison réalisée. Dans une autre colonne j'indique par OUI ou NON si la livraison a eu du retard ou pas.

Mais avec ma formule, si je n'indique pas de date prévue ou livrée cela m'indique une erreur #VALEUR!, j'aimerai enlever cette erreur et que la cellule n'indique rien s'il manque une date.

Quelle formule faire pour obtenir ce résultat svp ?

Merci d'avance,
Iso

https://www.cjoint.com/c/KAfohsctGtl

10 réponses

Messages postés
586
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
21 janvier 2021
34
Bonjour,

Tu inclus ta formule dans un SIERREUR
Au début
 =SIERREUR(SI(

et à la fin
 ;"")


Cordialement
Bonjour,

Merci mais ça ne fonctionne pas avec les cellules vides par contre, si je laisse une cellule vide ça me met oui ou non...

Cordialement,
Messages postés
1321
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
22 janvier 2021
133
Bonjour,
quelque chose m'interpelle dans ton fichier :

Il y a une date de livraison présente sans date de livraison prévue, est-ce normal ?
Bonjour,

Oui cela peut arriver qu'un fournisseur ne nous communique pas la date de livraison prévue.

Cordialement,
Messages postés
1321
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
22 janvier 2021
133
Pour que ça fonctionne, il faut supprimer les - :

=SI(OU(Tableau1[@[Livraison prévue le]]="";Tableau1[@[Date livraison]]="");"";SI(Tableau1[@[Livraison prévue le]]-Tableau1[@[Date livraison]]>=0;"OUI";SI(Tableau1[@[Livraison prévue le]]-Tableau1[@[Date livraison]]<0;"NON")))


sinon, si tu laisses les - :
=SIERREUR(SI(OU(Tableau1[@[Livraison prévue le]]="";Tableau1[@[Date livraison]]="");"";SI(Tableau1[@[Livraison prévue le]]-Tableau1[@[Date livraison]]>=0;"OUI";SI(Tableau1[@[Livraison prévue le]]-Tableau1[@[Date livraison]]<0;"NON")));"")
Justement, j'aimerai trouver une formule qui fonctionne peut importe s'il y a des tirets ou non dans les cellules
Messages postés
1321
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
22 janvier 2021
133
Tu voudrais une formule qui fonctionne qu'il y ait un tiret (ou autre) dans une cellule tout comme tu voudrais une formule qui fonctionne avec un vide dans la cellule ?
>
Messages postés
1321
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
22 janvier 2021

Je voudrais que si j'ai ma date prévisionnelle et ma date de livraison ça indique le non ou oui mais qu'en revanche s'il me manque une de ces deux dates ca n'affiche rien dans la cellule et lorsqu'il me manque la date la cellule peut soit être vide soit contenir un tiret.
Messages postés
23809
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
6 584
Bonjour à tous,

une date étant un nombre tu pourrais faire ainsi :
=SI(ESTNUM(A2);ta_formule;"")

eric
Bonjour,

Ca ne fonctionne pas, j'ai une erreur #valeur!
Messages postés
23809
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
6 584 > Iso
C'est que ta formule est incorrecte, c'est elle qui te retourne ça, pas ma proposition.
Messages postés
53128
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
15 107
Pour tenir compte de tous ces cas de figure :
=SI( ET(ESTNUM([@[Livraison prévue le]]) ; ESTNUM([@[Date livraison]]) ;
[@[Livraison prévue le]]=[@[Date livraison]]) ; "OUI" ; "NON" )

Cordialement.
Bonjour,

Ca indique "non" si une des cellules est vide ou si elle contient un tiret alors que j'aimerai que ça n'indique rien, que la cellule reste vierge.
Messages postés
1321
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
22 janvier 2021
133
Il serait bien de nous indiquer quelle formule tu as utilisé et qui ne fonctionne pas !

Il y a eu plusieurs propositions mais nous ne savons pas laquelle tu as retenu !
Messages postés
53128
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
15 107
C'est ma dernière offre :
=SI(OU(A2="";A2="-";B2="";B2="-");"";SI(A2<B2;"NON";"OUI"))