Fonction si multiple

Signaler
-
Messages postés
1321
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
22 janvier 2021
-
Bonjour,
je cherche la fonction qui me permettra de calculer le prix réduit de 10% si le nombre d'exemplaire est un multiple de4
merci d'avance car je suis nulle en fonctions et bonne année à toutes/tous

3 réponses

Messages postés
53130
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 janvier 2021
15 109
Bonjour.

=SI(NbEx/4=ENT(NbEx/4);Prix*90%;Prix)

Et la prochaine fois que tu poses une question sur Excel, pense à joindre ton fichier, ainsi que les formules essayées, même si elles sont fausses !
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers
Il existe aussi :
1) https://mon-partage.fr/
2) https://www.transfernow.net/

Messages postés
1321
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
22 janvier 2021
133
Bonsoir Raymond ,

réponses croisées !

Meilleurs vœux
Messages postés
53130
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 janvier 2021
15 109 >
Messages postés
1321
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
22 janvier 2021

Merci Yoyo !
Reçois également mes vœux pour 2021 :
Les optimistes prédisent "2021 sera meilleure que 2020, et 2022 encore mieux"
Les pessimistes disent "2021 sera pire que 2020, et hélas meilleure que 2022 !"
Messages postés
1321
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
22 janvier 2021
133 >
Messages postés
53130
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 janvier 2021

Je garde ta fonction optimistes , elle fonctionne à merveille ;-)
Merci Raymond de ta réponse !
je suppose que ENT correspond au multiple de 4 ? Mais pourquoi deux = dans la fonction ?
Messages postés
1321
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
22 janvier 2021
133
Bonsoir,

à adapter :


désolé mais rien compris :-(
A1 = nombre d'exemplaires (de livres par exemple)
B1 = prix du livre normal
C1 = prix déterminé par la fonction avec une réduction de 10% par rapport à B1 si uniquement A1 est un multiple du nombre 4 (donc applicable si A1 = 8, 12 ou 16 etc)
j'espère que je suis plus clair et je te remercie par avance
Messages postés
1321
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
22 janvier 2021
133 > gobois64
=SI(MOD(A1;4)<>0;B1*A1;(A1*(B1*0,9)))


SI c'est pas un multiple de 4, on multiplie A1xB1 sinon on multiplie A1xB1 et on applique une remise de 10%
Messages postés
53130
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 janvier 2021
15 109
Salut, gobois.

Tu avoues être nulle en fonctions.
La moindre des choses, par conséquent, est de regarder dans l'Aide d'Excel la signification, la syntaxe et le rôle de chaque nouvelle fonction !