Convertir les heures en centièmes [Résolu]

Signaler
-
Messages postés
25761
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
-
Bonjour,

Nous avons besoin d'additionner des heures puis de les convertir en centièmes pour calculer la prime.
Problème : lors du calcul nous avons été obligés de modifier le format de la cellule en [HH]:MM:SS sinon il ne cumule pas les heures (total supérieur à 24 H)
Autre problème : quand nous demandons la conversion de la cellule : tronque(H12*24;2) il indique une valeur négative totalement impossible ??

03:35:00
-20,41

Merci de votre aide précieuse !!

12 réponses

Messages postés
25761
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 726
Bonjour
????le formatage de cellule n'influe en aucun cas sur les calculs qui suivent, c'est juste une question d'affichage!
il doit y avoir un problème dans votre entrée de valeur horaire parce que testé chez moi, si je rentre 03:35:00 TRONQUE(cell*24:2) me renvoie bien 3,58
vérifier pour principe à l'affichage de H12en nombre /standard que la cellule renvoie bien la valeur num correspondante, à savoir:
0,149305556 (soit la fraction de jour , l'unité de temps d'Excel étant le jour de 24h)
et sinon, déposez un modèle de votre problème, par exemple ici:
https://mon-partage.fr
et revenez coller lien créé sur le site
à vous lire
crdlmnt

Merci pour votre réponse.
Vous m'avez perdu au niveau de l'affichage ?? Vous parlez bien du format de la cellule ?
et pour votre parfaite information je suis sur libreoffice calc et non sur EXCEL

Je ne suis pas sure de me faire bien comprendre... Dsl
https://mon-partage.fr/admin/SigaGvZr/GbDIigaR/
Messages postés
25761
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 726
pas moyen d'accéder à votre fichier, l'accès est verrouillé par un mot de passe ?
Oui je vous l'ai mis en commentaire !
Messages postés
25761
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 726
ok, j'ai fini par l'avoir, ( j'ai plus l'habitude des échanges sans mot de passe)
ouvert avec office, où est le problème
  • si je place en K26 la formule: TRONQUE(K25*24;2) j'obtiens bien 3,58

par contre vous avez plusieurs problèmes dans votre modèle
  • en F14, faute de frappe, l'horaire est entré avec un blanc avant les deux points, ce qui le transforme en texte
  • pour empiler des calculs après vos formules à conditions, mieux vaut utiliser ;0; pour une cellule vide que ;"";qui n'est pas toujours compatible avec une opération ultérieure (admis par SOMME(cell1:Cell2) mais renvoie #VALEUR avec cell1+cell2)

à vous lire
crdlmnt
Ps: ce que je voulais dire pour le formatage: si vous formatez un horaire en "nombre" la cellule vous renvoie une valeur décimale fragment de la journée, ça permet de vérifier qu'elle est bien numérisée (voyez avec F13 et F14! avant correction!:)
Au moment du partage de fichier, j'ai mis un commentaire avec le mot de passe et une validité d'1 jour.

Ok pour vous ?
La cellule qui m'embête est la H28, j'ai le même souci sur les cellules C32 et E32. Je ne comprends pas ...
Un grand merci pour votre aide !

Bien cordialement,
Messages postés
25761
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 726
En complément si ça n'est toujours pas résolu:
en P11 à tirer de P11 à P16:
=SI(I11<H11;I11+1-H11;I11-H11) pour éviter les résultats négatifs, ça devrait arranger H28
(type de formule à utiliser quand les horaires de fin dépassent minuit)
voyez ici:
https://mon-partage.fr/f/OBX8CDVo/
si tout va bien , merci de passer le sujet en résolu (bouton vert sous votre premier post)

bonne route
crdlmnt

Presque !! on y est presque !! Merci pour cette formule qui change la donne !
J'ai encore un souci sur les heures au delà de 22h (Colonne T) SVP
Il ne comprend pas que s'il n'y a rien = 0 il a l'air de calculer 24-22=2

Un grand grand merci à vous !!
Messages postés
25761
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 726
????
vérifiez que les valeurs en H et I soient bien nulles, dans mon, modèle je ne détecte pas de problème de ce genre, avec des cellule vides en H et I ou avec des 0
Et méfiez vous de Ocalc qui à quelque fois des réactions que personnellement je ne maîtrise pas
par exemple, quand je tape un 0 en I n'importe où entre 11 et 18 sauf 12 il me rentre la valeur de I12 soit 01:45
va savoir pourquoi!
si le problème subsiste, redéposez votre fichier avec la modif faite chez vous
crdlmnt
Vous parlez des HS (colonne P), moi je vous parle des interventions (Colonne T) après 22h svp.

Merci de votre aide !!
Messages postés
25761
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 726
Re, j'arrive!! 0 pour le système correspond à 24h, d'où le problème. Il y (a deux façons de traiter minuit, soit 24:00 soit 0)... mais en principe, si L11 est vide, il ne doit pas y avoir de résultat
en T11 voyez avec:
=SI(L11=0;SI(L11<$L$7;L11+1-$L$7;L11-$L$7))
pour gérer aussi le cas ou L11 fini le lendemain
à tirer sur la hauteur, en bloquant bien $L$7
revenez si soucis

crdlmnt
Hélas, ça ne marche pas... Je renonce... Merci pour tout !
Messages postés
25761
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 726
qu'est ce qui ne "marche pas "en colonne T ici:
https://mon-partage.fr/f/y2kmcn48/
Je n'ai pas de mots !! vous êtes un génie !
Merci de nous avoir ôté cette épine du pied !!!
Merci pour tout, prenez soin de vous.

Cordialement
Messages postés
25761
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 726
n'exagérons rien
je passe le sujet en résolu
revenez si soucis
bonne route
crdlmnt