Formule excel - Si contient [Résolu]

Signaler
-
Messages postés
3
Date d'inscription
mercredi 18 novembre 2020
Statut
Membre
Dernière intervention
18 novembre 2020
-
Bonjour,
J'ai beau essayé de faire plein de TEST, je ne trouve rien de concluant !

J'ai un taux de marge sur l'un de mes produits ( Colonne P3 ) ( 50.1279% )
Je souhaite mettre en place une remise maximum ( Exemple pour ce produit : 50.1279% de marge alors le commercial ne pourras faire une remise de 15% maximum à son client.

Marge >0% et <=10% => pas de remise
Marge >10% et <=20% => 5% de remise
Marge >20% et <=30% => 7% de remise
Marge >30% et <=40% => 10% de remise
Marge >40% et <=50% => 12% de remise
Marge >50% et <=60% => 15% de remise

Qu'elle serait la formule svp ?
Merci par avance pour votre retour et votre aide.
Bonne journée.

5 réponses

Messages postés
2501
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
18 novembre 2020
413
Bonjour,

Faisable avec des SI / ET imbriqués:

=SI(ET(A1>=0;A1<=10);"Pas de remise";(SI(ET(A1>10;A1<=20);B1*0.05;((SI(ET(A1>20;A1<=30);B1*0.07;(Et ainsi de suite ...)))))


A1 étant la marge et B1 le prix du produit ;)

Cdlt.
Merci pour votre retour rapide et votre aide.

=SI (ET (P3>=0;P3<=10);"Pas de remise";(SI(ET(P3>10;P3<=20);Q3*0.05;((SI(ET(P3>20;P3<=30)Q3*0.07;((SI(ET(P3>30;P3<=40);Q3*0.1;((SI(ET(P3<40;P3<=50);Q3*0.12);((SI(ET(P3>50;P3<=60);Q3*0.15);((SI(ET(P3<60;P3<=100;Q3*0.15)

Voici la formule Finale ( P3 = Taux de marge / Q3 = Prix de vente produit )

Quand je clique sur entrée, cela ne fonctionne pas. J'ai un message d'erreur : Nous avons rencontré une erreur dans cette formule...

Merci pour votre retour
Messages postés
1239
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
18 novembre 2020
123 >
Messages postés
1239
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
18 novembre 2020

Si jamais ça n'est pas ça, merci de nous dire ce qu'il devrait y avoir comme résultat en S3 !
Messages postés
2501
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
18 novembre 2020
413 >
Messages postés
1239
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
18 novembre 2020

Vérifiez votre formule, il y'a deux fois 0.15 ;)
Messages postés
1239
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
18 novembre 2020
123 >
Messages postés
2501
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
18 novembre 2020

J'ai repris la formule de l'auteur en apportant des modifications.

Et dans le post d'origine :

Marge >0% et <=10% => pas de remise
Marge >10% et <=20% => 5% de remise
Marge >20% et <=30% => 7% de remise
Marge >30% et <=40% => 10% de remise
Marge >40% et <=50% => 12% de remise
Marge >50% et <=60% => 15% de remise


Il n'y a pas le % de remise de 60% à 100%...

Le 0,15 pour la fourchette >60% <=100% est juste à modifier par l'auteur.

Mais si mes (tentatives de) solutions apportées ne vous conviennent pas, je vous laisse traiter le sujet !
Messages postés
2501
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
18 novembre 2020
413 >
Messages postés
1239
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
18 novembre 2020

Pas de soucis ont est là pour discuter j'avais pas fait gaffe à ce détail effectivement , mais du-coup on peut alléger en mettant un seul P3>05 et <1 ou même virer le Et en mettre juste si P3 > à 0.5
Messages postés
2501
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
18 novembre 2020
413 >
Messages postés
1239
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
18 novembre 2020

Toujours pas ;)
Messages postés
2872
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
18 novembre 2020
774
Salutations à tous

Une autre méthode avec une rechercheV

https://www.cjoint.com/c/JKskwakHf4I

Cordialement
Messages postés
2872
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
18 novembre 2020
774
Le fichier en retour avec la méthode ci-dessus décrite (j'ai calculé le prix de revient déduit éventuellement de la remise appliquée d'après le taux de marge

https://www.cjoint.com/c/JKslNDLPa2I

Cordialement
Messages postés
2872
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
18 novembre 2020
774 >
Messages postés
2872
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
18 novembre 2020

Ma proposition convient-elle à ta demande ?????

Cordialement
Messages postés
3
Date d'inscription
mercredi 18 novembre 2020
Statut
Membre
Dernière intervention
18 novembre 2020

Bonjour

Non pas vraiment car , sauf erreur de ma part, le calcul du prix planché n'est pas bon.
587.00 - Maximum 15% = ( 587 - 15% = 88.05 587 - 88.05 = 498.95 € )

Le prix maximum que le commercial pourra baisser son produit est de 498.95€


Sur la ligne 3 : M3 = P.A / P3 Taux de marge / Q3 : P.V
Mon taux de marge sur le produit est de 50.1279% soit située dans la catégorie suivante : Marge >50% et <=60% => 15% de remise
Il faudrait donc que dans la zone S3 , il soit indiqué : 15 %


Si le prix d'achat augmente, alors la marge sera moins importante ( Exemple : Celui-ci va passer de 50.1279% à 48% )
Alors il sera situé dans la catégorie suivante : Marge >40% et <=50% => 12% de remise
Donc dans la case : S3 , il faudra qu'il soit indiqué : 12%

Merci
Messages postés
2872
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
18 novembre 2020
774
Autant pour moi, décidément c'est pas mon jour aujourd'hui,

La formule en R3 à modifier comme ceci =SI(Q3="";"";Q3-(Q3*RECHERCHEV(P3;Remise;2;1))) ce qui donne le bon résultat

https://www.cjoint.com/c/JKsohX8hxII

Cordialement
Messages postés
1239
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
18 novembre 2020
123
En soustrayant Q3 à la fin :

=ABS(SI(ET(P3>=0;P3<=0,1;P3<>"");"Pas de remise";SI(ET(P3>0,1;P3<=0,2);Q3*0,05;SI(ET(P3>0,2;P3<=0,3);Q3*0,07;SI(ET(P3>0,3;P3<=0,4);Q3*0,1;SI(ET(P3>0,4;P3<=0,5);Q3*0,12;SI(ET(P3>0,5;P3<=0,6);Q3*0,15;SI(ET(P3>0,6;P3<=1);Q3*0,15;"")))))))-Q3)

= 498,95

Soit tu utilises la formule de PapyLuc (salutations au passage) soit tu utilises cette formule. Tu es le seul décideur ;)
Messages postés
3
Date d'inscription
mercredi 18 novembre 2020
Statut
Membre
Dernière intervention
18 novembre 2020

Trop fort !! Merci beaucoup pour vos retours, votre rapidité !

Bonne fin de journée à vous et encore merci !