Programme problème C++

Signaler
Messages postés
7
Date d'inscription
jeudi 29 octobre 2020
Statut
Membre
Dernière intervention
17 novembre 2020
-
Messages postés
487
Date d'inscription
dimanche 7 février 2016
Statut
Membre
Dernière intervention
17 novembre 2020
-
Fonction Seconde (a, b, c : entier) ;
DeclarationVariable
delta, x1, x2; double;
Debut
Si a = 0 Alors
Si b = 0 Alors
Si c = 0 Alors
Ecrire "R est la solution"
Sinon
Ecrire "Impossible"
FinSi
Sinon
x1 <-- - c / b ;
Ecrire (x1) ;
FinSi
Sinon
delta <--b*b – 4*a*c ;
Si delta < 0 Alors
Ecrire "Pas de solution dans R"
Sinon
Si delta = 0 Alors
x1 <-- -b / 2*a ;
Ecrire "Solution double ", x1 ;
Sinon
x1 <-- - b + ???????????????????? / 2*a ;
x2 <-- - b - ???????????????????? / 2*a ;
Ecrire x1, x2 ;
FinSi
FinSi
FinSi
Fin

j'arrive à renter mon code avec ce pseudocode pouvez-vous m'aider

2 réponses

Messages postés
15113
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
18 novembre 2020
614
Messages postés
487
Date d'inscription
dimanche 7 février 2016
Statut
Membre
Dernière intervention
17 novembre 2020
63
Bonjour,

Ça doit être la première ligne qui te bloque, elle s'écrit :
void  Seconde(int a, int b, int c) {

ensuite continue et reviens nous demander si une autre ligne te bloque.