Listes déroulantes en cascade [Résolu]

Signaler
Messages postés
312
Date d'inscription
mardi 19 février 2008
Statut
Membre
Dernière intervention
16 avril 2021
-
Messages postés
312
Date d'inscription
mardi 19 février 2008
Statut
Membre
Dernière intervention
16 avril 2021
-
Bonjour,
J'ai un fichier Excel, avec une partie en VBA.
Il y a deux colonnes (M & N) dans la colonne M j'ai une liste déroulante "envoyé" ou "en attente"; je vais chercher les données de cette liste en U22 et 23 qui sont en dehors de la vue de ma feuille.
Dans ma colonne N, je voudrais une liste reprenant "Contrat Seul" ou " Contrat + FdL" à la seule condition que la résultat de la colonne M soit "Envoyé".
Je pense qu'il s'agit là de liste déroulante en cascade, j'ai regardé plusieurs tutos, mais à chaque fois ça ne fonctionne pas.
Merci de votre aide


Configuration: Windows / Chrome 86.0.4240.111

3 réponses

Messages postés
26022
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 mai 2021
5 927
Bonjour
sous réserve de bonne compréhension exemple à adapter:
liste de référence de validation: E2:E3
colonne N pour validation si on commence en ligne 2:
données/ validation / liste
=SI($M2="Envoyé";$E$1:$E$2;"")
crdlmnt
Messages postés
312
Date d'inscription
mardi 19 février 2008
Statut
Membre
Dernière intervention
16 avril 2021
26
Merci beaucoup Vaucluse, mais ce n'st pas exactement ce que je cherche.
en effet, si j'ai "envoyé" dans la première colonne, je dois avoir une seconde liste dans la deuxième colonne me laissant le choix entre "Contrat Seul" ou " Contrat + FdL"; mais si la première colonne me donne :"en attente" alors je ne dois rien avoir en seconde colonne.

merci de votre aide, je continue à chercher. Je viens de suivre un tuto avec "decaler" et je vais tenter de mettre cela en musique.
Merci
Messages postés
26022
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 mai 2021
5 927
alors je ne comprend pas! ce n'est pas ça que vous cherchez?
https://mon-partage.fr/f/8z2jWY1L/
Messages postés
312
Date d'inscription
mardi 19 février 2008
Statut
Membre
Dernière intervention
16 avril 2021
26
Bonjour Vaucluse,
c'est exactement ce que je cherchais ! mais au départ, je n'avais pas bien compris ce que vous proposiez.
Un grand merci, je vais de suite mettre cela dans mon fichier.
Excellente journée à vous et protégez vous !