Formule avec plusieurs conditions [Résolu]

Signaler
Messages postés
44
Date d'inscription
lundi 21 mai 2012
Statut
Membre
Dernière intervention
22 octobre 2020
-
Messages postés
1314
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
18 janvier 2021
-
Bonsoir,

Je sèche complétement sur une formule après en avoir testé plusieurs. Je vous explique mon souci et vous mets le fichier concerné :

en G61 doit s'afficher le total de G23+G32+G41+G50+G59 si AE9 ou A13 ou Y23 sont cochés sinon G61 doit afficher le total de G23+G32+G41+G50+G59-G16-G17-G18-G19

https://www.cjoint.com/c/JJvuCGEVdcD

Je remercie d'avance ceux qui pourront m'aider ;-)



Configuration: Windows / Chrome 86.0.4240.75

4 réponses

Messages postés
1314
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
18 janvier 2021
130
Bonsoir,
en G61 :
=SI(OU(AE9<>"";A13<>"";Y23<>"");G23+G32+G41+G50+G59;G23+G32+G41+G50+G59-G16-G17-G18-G19)

Messages postés
44
Date d'inscription
lundi 21 mai 2012
Statut
Membre
Dernière intervention
22 octobre 2020

Bonjour Yoyo01000

J'ai oublié une condition et j'en suis désolée :-(

Si AE9 ou AE13 coché mais que Y25 coché alors G61 affiche G23+G32+G41+G50+G59-G16-G17-G18-G19
Messages postés
1314
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
18 janvier 2021
130
Si AE9 ou AE13 coché mais que Y25 coché ?

Dois-je comprendre AE9 OU AE13 coché ET Y25 coché ?
Messages postés
44
Date d'inscription
lundi 21 mai 2012
Statut
Membre
Dernière intervention
22 octobre 2020

Oui c'est ça
Messages postés
1314
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
18 janvier 2021
130 >
Messages postés
44
Date d'inscription
lundi 21 mai 2012
Statut
Membre
Dernière intervention
22 octobre 2020

Ben...y a un moment où il va falloir donner toutes les conditions, si vous voulez qu'on vous aide !!!
Messages postés
44
Date d'inscription
lundi 21 mai 2012
Statut
Membre
Dernière intervention
22 octobre 2020
>
Messages postés
1314
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
18 janvier 2021

Je suis vraiment désolée, je vous donne donc tous les éléments avec des chiffres.

SI AE9 coché et Y23 coché, G61 doit afficher 250 (G23+G32+G41+G50+G59)
SI AE9 coché et Y25 coché, G61 doit afficher 210 (G23+G32+G41+G50+G59- G16-G17-G18-G19)

SI AE10 coché et Y23 coché, G61 doit afficher 250 ((G23+G32+G41+G50+G59)
SI AE10 coché et Y25 coché, G61 doit afficher 210 (G23+G32+G41+G50+G59- G16-G17-G18-G19)
Messages postés
1314
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
18 janvier 2021
130 >
Messages postés
44
Date d'inscription
lundi 21 mai 2012
Statut
Membre
Dernière intervention
22 octobre 2020

=SI(ET(AE9<>"";Y23<>"");G23+G32+G41+G50+G59;SI(ET(AE9<>"";Y25<>"");G23+G32+G41+G50+G59-G16-G17-G18-G19;SI(ET(AE10<>"";Y23<>"");G23+G32+G41+G50+G59;SI(ET(AE10<>"";Y25<>"");G23+G32+G41+G50+G59- G16-G17-G18-G19;""))))
Messages postés
44
Date d'inscription
lundi 21 mai 2012
Statut
Membre
Dernière intervention
22 octobre 2020
>
Messages postés
1314
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
18 janvier 2021

Merci infiniment ça fonctionne.

Encore toutes mes excuses pour le manque d'information
Messages postés
1314
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
18 janvier 2021
130 >
Messages postés
44
Date d'inscription
lundi 21 mai 2012
Statut
Membre
Dernière intervention
22 octobre 2020

Il faut bien penser à donner toutes les informations dès le départ, pour la prochaine fois ;-)
=si(ou(l'une des trois conditions est vrai);alors somme; si faux l'autre somme)
=si(ou(ae9;a13;y23)=“ “;somme(G23;G32;G41;G50;G59);somme(G23;G32;G41;G50;G59;-G16;-G17;-G18;-G19)
" " (avec espace) = rempli alors que "" = vide
si cela ne fonctionne pas il faut trouver l'équivalent de = case cochée a la place de " "