Fonction RECHERCHEV [Résolu]

Signaler
Messages postés
102
Date d'inscription
lundi 7 janvier 2019
Statut
Membre
Dernière intervention
21 octobre 2020
-
Messages postés
102
Date d'inscription
lundi 7 janvier 2019
Statut
Membre
Dernière intervention
21 octobre 2020
-
Bonjour à tous,

Voilà je dispose d'un fichier EXCEL afin de calculer ma consommation.

Là où j'aurais besoin de vous c'est dans ma feuille "TABLEAU DONNÉES".

J'y est rentré ma liste de mes camions avec leur immat et leur marque.
Il y a des N° de camion avec des lettres, c'est pour les différencier des autres.

Ce que j'aimerais comprendre, c'est lorsque l'on regarde mon tableau, il y a déjà des trous dans le camion n°1000 (trous colonne H & I) or mes formules sont correctes.
J'ai remarqué que lorsque je double-cliquais sur le n° du camion, et que je faisais "Entrer" les calculs colonnes H & I se font mais la colonne F disparait à son tour.

J"ai remarqué que les camions avec des lettres tous les calculs sont bons, or dès lors que l'on passe à un chiffre rond, cela plante ou alors note des fausses informations.

Savez-vous d'où cela peut venir et m'apporter de l'aide stp ?

Lien du fichier : https://www.cjoint.com/c/JJvkXbalPNs

Cordialement

Rom1

2 réponses

Messages postés
25629
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
5 629
Bonjour
pas sur d'avoir la solution mais regardez votre formule en H et I ligne 4 , elle dit que si RECHERCHEV ne trouve pas dans TableauExportVEHCO il faut aller chercher dans : TableauExportVEHCO qui en est fait est la même adresse!
Et aussi si votre formule ne sretrouve pas dans le premier , elle renvoie "" et ne va pas plus loin; écrivez
=SIERREUR(SI(RECHERCHEV([@[N° Parc]];TableauExportVEHCO;10);RECHERCHEV([@[N° Parc]];Tableauxxxxx(?);10));"")
à condition bien sur que la valeur cherchée se trouve dans l'un ou l'autre des tableaux , sinon i faut rajouter un niveau SIERREUR
=SIERREUR(SIERREUR(SI(RECHERCHEV([@[N° Parc]];TableauExportVEHCO;10);RECHERCHEV([@[N° Parc]];Tableauxxxxx(?);10));"");"")
Tableauxxxxx étant bien sur l'adresse du second tableau où chercher (probablement KM plutôt que VEHCO?)à
revenez si problème autre!
crdlmnt
plutôt:


Messages postés
102
Date d'inscription
lundi 7 janvier 2019
Statut
Membre
Dernière intervention
21 octobre 2020

Bonjour Vaucluse,

Pour mon cas, je veux qu'ils sortent tous les chiffres, afin d'avoir à la fin une vue sur ma conso moyenne de mes camions avec les outils GIR et VEHCO.

Cependant pourquoi cela prend les données pour les véhicules avec une lettre et non les arrondi.

du coup je suis passé sur une formule en SOMME.SI qui va donc rechercher mon n° de parc dans mes exports, et cela fonctionne.

Merci tout de même à toi pour ta réponse et ton raisonnement.

Cordialement

Rom1