Recherche 2 critères sur 2 bases [Résolu]

Signaler
-
Messages postés
25592
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 novembre 2020
-
Bonjour,

Je souhaiterai trouver par une formule le n° client en base 1 qui est situé en base 2 par rapport au n° siret et la ville

3 réponses

Messages postés
5
Date d'inscription
mardi 20 octobre 2020
Statut
Membre
Dernière intervention
26 octobre 2020

Messages postés
25592
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 novembre 2020
5 615
Bonjour
en supposant que vous n'avez qu'un client avec le même N° de siret dans la même ville?
la formule en base1!A2:
=SIERREUR(INDEX(base2!$B$2:$B$1000;EQUIV($F2&J2;base2!$A$2:$A$1000&base2!$O$2:$O$1000;0));"")
attention:
cette formule est matricielle, elle doit être entrée avec la touche enter en maintenant ctrl et shift enfoncées
(elle doit s'afficher automatiquement entre accolades dans la barre de formule)
formule assez gourmande en capacité, bien limiter les champs aux nombres de lignes utiles (dans l'exemple de 2 à 1000) et sa recopie aussi en base 1
revenez si soucis avec ça
crdlmnt
Messages postés
5
Date d'inscription
mardi 20 octobre 2020
Statut
Membre
Dernière intervention
26 octobre 2020

Super, merci beaucoup ça fonctionne.
Messages postés
25592
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 novembre 2020
5 615
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt