Fonction si avec plusieurs critères [Résolu]

Signaler
-
 LinDouch42 -
Bonjour,

J'ai besoin d'une formule pour gérer des tournées.
Si la "date" est un samedi, que la date est dans le mois correspondant à la période, alors 1 sinon 0.
Jusque là ma formule fonctionne bien :
=SI(ET(AV$6<$C$2;AV$5="Sam");1;0)
Cellule av6 correspond à la date
Cellule C2 correspond a la date de fin de mois


Mais je dois rajouter un critère lié au jours fériés : si cette date "av6" est un jour férié, information que je trouve dans une autre feuille dans une liste de jrs fériés, alors pas de tournée et donc je voudrais un 0.

pour résumer : je veux 1 dans ma cellule, si c'est un samedi, si c'est dans le mois, si c'est pas un jour férié, si non un 0

Ceci me permettant de calculer le total de mes tournées en fin de mois.

Merci a tous pour votre aide

2 réponses

Messages postés
25396
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 octobre 2020
5 535
Bonjour
si votre formule fonctionne bien il suffit de compléter les "ET", mais je n'ai pas trop compris si vous voulez 0 avec un jour férié ou pas?
si on suppose que la date est en AV6
=SI(ET(AV$6<$C$2;AV$5="Sam";NB.SI(listfériés;AV$6)=0;1;0)

mais pour éviter le "Sam en AV5,vous pouvez utiliser directement la date de AV6
=
=SI(ET(AV$6<$C$2;JOURSEM(AV$6;2)=6;NB.SI(listfériés;AV$6)=0;1;0)

à adapter bien sur selon vos données
crdlmnt


Bonjour,

Merci beaucoup, cela fonctionne.

Cdt