Recherchev dans 2 tableaux de taille différente [Résolu]

Signaler
Messages postés
6
Date d'inscription
vendredi 16 octobre 2020
Statut
Membre
Dernière intervention
21 octobre 2020
-
Messages postés
6
Date d'inscription
vendredi 16 octobre 2020
Statut
Membre
Dernière intervention
21 octobre 2020
-
Bonjour,

Je débute dans libre office calc et rencontre un petit souci avec la fonction rechechev.

J'ai une très longue liste de numéros de série indéchiffrables.
Cette liste peu contenir plusieurs fois le même numéro.

En parallèle, j'ai une plus petite liste où ces numéros sont associés à des noms.

J'ai créé une fonction recherchev pour ramener les noms associés aux numéros.
Cela fonctionne, au début.

Mais mon problème est que quand "je tire la languette" (désolé, je n'ai pas encore le vocabulaire technique adéquat), au bout d'un moment rechechev s'effectue en dehors de la liste de noms.

Il faudrait que je puisse faire retourner recherchev au début de la liste de noms (boucle? mais j'ai lu quelque part que la bouche n'était pas conseillée et qu'il y avait moyen de procéder autrement)

Bref, je suis bloqué.
Quelqu'un pourrait-il m'aider?
Merci beaucoup



Configuration: Windows / Firefox 81.0

7 réponses

Messages postés
2084
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
16 octobre 2020
342
Bonjour
Un exemple de la formule
il ne faut pas oublier les $

=RECHERCHEV(A3;$H$2:$I$19;2)
Crdlt
Messages postés
6
Date d'inscription
vendredi 16 octobre 2020
Statut
Membre
Dernière intervention
21 octobre 2020

Merci JCB40 d'avoir répondu si vite

Voici ma formule : =RECHERCHEV(G30;$Listes.E6:$Listes.I14;5;0)
Les $ se sont mis automatiquement.
Messages postés
2084
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
16 octobre 2020
342
Listes correspond a quoi ?
Une liste que tu as enregistrée?
Le nom d'une feuille?
Crdlt
Messages postés
6
Date d'inscription
vendredi 16 octobre 2020
Statut
Membre
Dernière intervention
21 octobre 2020

Listes correspond à la feuille de ma liste de noms.
C'est à cette feuille que ma formule se réfère pour trouver la correspondance associée à G30 (numéro de série). Cela fonctionne.

Mais lorsque j'étire la cellule de résultat vers le bas, pour trouver les autres correspondances, la formule ne fonctionne plus, car à chaque nouvelle ligne, la formule passe de "$Listes.D6:$Listes.H14" à ";$Listes.D7:$Listes.H15" (j'ai essayé avec $Listes.$x$y, idem)

Comment puis-je faire pour convertir ces numéros de séries avec les noms auxquels ils sont associés?

N.B.
Je ne suis même pas sur que recherchev soit un bon choix, mais comme je débute je n'en connais pas d'autres. J'ai bien pensé utiliser EQUIV mais il semble que cela soit sensible à la casse et il la casse de mes numéros de série varie...
Messages postés
2154
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
21 octobre 2020
860
Bonjour
cette formule devrait suffire
=RECHERCHEV(G30;Listes.$E$6:$I$14;5;0)



Un exemple de classeur dépersonnalisé serait à mettre sur Cjoint pour avoir les meilleures réponses possibles.
Comment déposer sur Cjoint.fr
Messages postés
2084
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
16 octobre 2020
342
Formule a tester

=SI(A1="";"";RECHERCHEV(G30;Listes!$E$6:$E$14;5;0))
Cordialement
Messages postés
6
Date d'inscription
vendredi 16 octobre 2020
Statut
Membre
Dernière intervention
21 octobre 2020

Au temps pour moi, c'était bien un problème de $ mal placés :)
J'ai appris quelque chose...

Je vous remercie beaucoup pour vos réponses.

Bonne journée